If I edit any property of my character, editor crashes. But if I duplicate the BP, then it works?

So I wasted my entire day trying to figure what was wrong with my code that was causing the editor crash as soon as I edit the value of any property in the editor for my character blueprint. Then eventually I found out that if I duplicate that Blueprint (Ctrl+w in content browser), then the copy works, but the original doesn’t??? Now editing the original crashes the editor, but editing the copy doesn’t. How?? Why?

This has several weird implications:

  1. there was nothing wrong with my code, it was a bug in the editor all along

  2. so duplicating doesn’t actually… duplicate? If one copy works and the other doesn’t… this means the duplicate is different from the original. What the hell does duplicating an asset does then? What exactly is different from the original and the duplicate?

  3. the glitched original blueprint and working duplicate look identical in the editor. Does this means there are some hidden configuration in the blueprint asset file that is not visible in the editor? How can I visualize all there really is about this particular blueprint that puts it in this weird glitched state so I can figure out what is wrong with it?

  4. and more importantly… What do I do now? I want to keep working on this project, but it’s impossible in this glitched state. My first instinct was: well, if the duplicate works… Then I will just delete the original and the delete dialog will replace all references to the working copy: boom all my problems are solved… Well… that didn’t work. Trying to delete it just gives me a shitload of non sense errors. I cannot even delete the glitched asset… So I open the reference viewer and there are several dozens of references to it that I would have to replace manually.

This isn’t the first, nor the second time some blueprint gets into some incomprehensible glitched state, that has nothing to do with my code. That recreating that blueprint fixes the problem. But it’s the first time it happens to something so big that takes so much time to fix.

Why does this keeps happening? How the hell do you guys deal with this?

I"ve had it happen a couple times, but not for a while now. The only way I could fix it was by either redoing the affected BP or duplicating it, and redoing references etc.

These days, i backup my project quiet alot to avoid this sort of thing.

> These days, i backup my project quiet alot to avoid this sort of thing.

I push commits several times a day. But by the time I notice this particular problem (only happens when I try to edit that one specific blueprint) then the problem was probably originated some 5-10 commits behind. I tried checking out the last couple of commits and they both have the same problem.

Sometimes when editing any sort of blueprint class, you must delete it and then re-add it back into the editor or you get weird crash or bugged out blueprints. When you copied it, it created a new/fresh updated blueprint instance that was correct, while the original one was stale and bugged.