If actor is sideways if thy collide with anything they jitter/teleport over a little

I’ve made an actor that can go around a planet but when their at the equator of the planet/sideways if the capsule collides with anything the character teleports a little to the right I can’t seem to figure out why it’s happening anyone know why

I guess the player is trying to avoid the planet. The only ways to avoid that would be turn off player or planet collison, or move them slightly further out.

Do you know if there’s a way to make the character not avoid objects or is that just not possible

It’s built into the character to avoid objects when then overlap with it’s collision. That’s usually what you want. If you want that not to happen, you need to turn off the collision.

Oh ok well hopefully I can find a solution it seems though that it happens when he’s sideways only so I wonder if there any way to make the game think the character is still up right