IDE crashes when simulating or playing

The IDE crashes after a brief pause after hitting play or simulate. I’ve recently been playing with foliage and have since removed all foliage from the map. The crash still occurs. The crash report shows nothing of any use, just a GUID and a note that it crashed. Is there any way I could get more info to try to resolve this myself?

I found the saved logs for my project. This is the crash event:

[2014.05.28-06.19.34:810][222]LogWindows: Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.1\Engine\Source\Runtime\Core\Public\Containers\Array.h] [Line: 518]
Array index out of bounds: 0 from an array of size 0

It seems a lot like my project has become corrupt somehow. Is there an easy way to clean it up? I know I can start a new one and pull all the assets across and it would probably be good practice, but I’d also like to try recovering this one.

Hi Antidamage,

Sorry to hear about the project being corrupted, but I’ll see if I can help you sort this out.

Are you able to reproduce this in a new project that you set up? If so, would you mind uploading this for me to take a look at?

If you are able to repro it could you detail the steps and relevant information (How to write a bug report)? Mainly just need the build you’re on, the repro steps, and system specs.

Have you also been able to copy/migrate your project files to a new project and the crashing stop?

Thank you!

Tim

I can replicate the crash if I make a new project and pull the existing .umap file into it. Other than that I can’t determine what’s causing the issue beyond what I posted above. The only other clue I can give you is that I had recently been working with adding and removing foliage using the brush.

At a guess, something expects an array to have data when it doesn’t which could pretty much be anything, but it may suggest an improper cleanup after a reference to some foliage was removed inside the level.

Additionally, leading up to this I did somehow have a single foliage element attached to a static mesh somehow by accident. When I went to shift-control-click to remove this piece of foliage the project crashed every time. I had to delete the mesh it was attached to in order to remove it. Not 100% sure that this is related to the current crash though.

I’ve since begun a new project and only brought the content assets over and started a new level.umap which resolved it. I’m needing to re-do all the elements like landscapes from scratch though, so a way to bring those over one by one would not only be great but would either rebuild the broken data or allow me to identify which element is failing.

If you open just that .umap file in a new level do you still get the crash? If so, would you attach that file here for me to take a look at?

I’m also curious about the crash with the foliage being removed from a static mesh.

Thank you!

Tim

Is the .umap file not the level? I’ll give it a go tonight when I get home as well as attach the crash log.

I’ll try to replicate the static mesh attachment crash then too.

Incidentally, the first crash (clicking play, array member issue) doesn’t bring up the crash reporter, it simply shuts down.

Yes the .umap file is the level file. The reason I ask to create a new level is to test whether it’s confined to that map or the project itself, and if you can replicate the issue in a new project then we can assess better where to start narrowing down what may have or still be causing the issue.

Thanks!

Tim

Hi Antidamage,

I’ve not heard back from you in a few days. I’m going to mark this as resolved for tracking purposes. If you are still having the issue please feel free to comment back on this post and I’ll see what I can do to help you!

Thank you!

Tim

I wasn’t able to replicate it back then. However since the release of 4.3 and Speedtree I’ve begun using foliage again and it’s quickly re-manifested.

I imported 5 trees and painted them on to the terrain. Then I deleted the source assets from inside UE without removing them from the foliage list. Now whenever I try to remove them from the foliage list, UE crashes instantly.

Additionally, if I try to replace the ghost references with references to new assets, UE crashes.

What do you need to debug this? A copy of the level?

If you want you can link the level here or send me a PM on the forums if you want it stay private. This would be the quickest way to replicate the issue and see if I can recreate in a new project.

Thank you!

Tim

Not a problem, here’s the level:

The first five foliage assets no longer exist in the content browser so references to them should have been removed from the foliage list.

The level is now quite butchered.

I re-import my trees as new assets to see if that would fix the issue of shaders needing to re-compile constantly. I then replaced all the instances of the old assets on the terrain which was successful, but when I deleted the old assets UE crashed. Now I have 12 broken foliage instance elements inside the foliage painter window that I can’t replace with new assets or remove and no trees on the map.

I’m not sure what a “cluster” is but I’m noticing in the Instance Settings the cluster count on the asset that probably crashed it is -572,662,307 and has zero instances. The tree definitely still appears on the map (it’s the only one to do so).

I added a shared foliage setting for the latest six broken foliage references. Then deleted one of them - this deleted all six of the latest broken foliage references. It didn’t remove the original six. I tried the same process with the original six broken assets and they’re still there. Although they show no mesh, clicking the “find content in browser” option takes you to the only remaining tree I can’t delete.

ALSO, this tree is still on the terrain! I can’t remove it as none of the foliage mesh instances are using it.

Finally, it crashed again and when UE loaded back up, all the foliage assets are gone. All of the trees I was trying to delete are gone. There’s also areas in the terrain where the mesh is zeroed out, so that’s a writeoff. I’ll have to go back to an earlier version with Git. I’ll upload the new very broken level file shortly first though.

I’ve reverted to an earlier version of the level. I’m noticing some strange foliage behaviour now that I’m using more of the settings:

Setting up a group of meshes to use shared foliage instance settings seems not very useful. Yes, it shares settings. Including the mesh selection. That doesn’t make sense.

I can’t break each item out of the shared settings. Only the first asset could have the shared instance settings removed. None of the others can, the button just does nothing.

I can’t replace any of the meshes with an asset from the content browser. Again, this worked once then stopped working entirely. Nothing happens.

What’s going on with foliage? Can we expect this to improve? It seems like a pretty fundamental thing and it wouldn’t be understating it to say it renders entire levels unusable once it’s been touched.

Hello,

Thank you for your report. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you