Download

ID Name Changes everytime I compile the Blueprint

I have a really big problem with recent engine versions 4.15 and I also tried 4.16. My setup is a follows. I have a Main Actor Blueprint that holds various child actors. All of these child actors contain a static mesh. Like this i was able to identify each of the objects IDs with a linetrace. I do it this way because. 1. When I would have just put static meshes into my main actor it would only return the main actor ID. 2. When I would trace for names it would not return the names in the compiled project, just in the editor.

So far this worked quite well in the past. But starting with 4.15 this changed. The first problem is those object IDs became miles long. Something like “colorMain_GEN_VARIABLE_CC_color_C_CAT8” While this is annoying it´s not a big problem. But my real problem now is that whenver I change the main or child blueprints and compile them, the last number starts to count up once I restart the engine. Something like this "colorMain_GEN_VARIABLE_CC_color_C_CAT10 "

In the project I´m currently working I also have these kinds of actors from previous engine version. They do not have this problem. Only actors that are fresh created in the new engine. I compared those actors and all of their settings but I can´t find a difference expect that newly created child actors have a drop down “child actor template” while the old ones have not. But this only redirects to the settings in the child actor. Any help is much appreciated.

This is why I don’t really like these blueprints. Is there a bug in the child blueprints. What is the master blueprint doing to cause it to keep changing child id’s? I wonder if these long object id names cause compiling issues with the compiled project since window don’t like long names.