Icon not being set for window and task bar

We have an icon set in project settings/window. Our package build (windows 32 bit) produces an EXE with that icon correctly. It seems to display correctly at all sizes in windows explorer.

However when we run in windowed mode the app the icon that appears in the top left hand corner of windows and the icon that appears on the taskbar are the generic ‘application’ icons.


I just packaged Shooter game with 4.9 and it has the same issue as our game. The icon is correct in windows explorer but the window and task bar (and also in task switcher [alt-tab]) is is the default icon.

Hey TheZMan,

Thank you for noticing this issue with the engine. We created a bug for this back in September. UE-21446 is currently on our ‘To Do’ list and is not resolved at this time. If you’d like to check up on this bug in the future, please reply back and we will assist you further.

Thanks, have a great day!

I am facing same problem…

Is there any update for it?

It’s fixed but it’s not released yet, please be on the lookout!


What is the CL that it is fixed in?


UE-21446 was sent back as not fixed on the latest CL it was tested on. It’s back to being worked on at this time. Please check back soon.

Thank you!

Any update?

UE-21446 was verified fixed in changelist 2801406.

I’m using 4.9.2 built from source. How do I incorporate the fix so the icon that is uploaded via Project Settings > Game Icon is included when packaging for Windows. As far as a I know, the public cannot see the changelog of UE so we need some more info here.

In 10.4 the problem still exists.

I verified that this issue has been corrected for 4.11.


I am very much interested in this too, as we are actually working on the 4.9.2 and we won’t update version until the release of our game. Did you get any news about this or any workaround ? Thanks

This issue was fixed in 4.11 (only the preview builds are out yet). There was not a workaround that I know of that will fix this issue.

Ok, we found finally a way to do this without modifying the .exe or upgrading to the latest engine version. All of you have to do is to add the following include in your Ressource/Windows/‘ProjectName’.rc :

#include "Runtime/Launch/Resources/Windows/resource.h"

Then, the icon you can set inside your project settings will work as intented !

Thanks for providing this work around, it’s greatly appreciated!

Can you please help me with the file, I can’t find this path. Even cannot find the Ressource folder.


I found an [older AnswerHub][1] post that had slipped my mind. You’ll have to add it into your code through the .rc file like it’s done within our samples.

Window icon don't change on package build - Platform & Builds - Epic Developer Community Forums

This doesn’t seem to be fixed. I am still running into the same issue as the OP packaging a shipping windows 64-bit build using 4.11.1.

Another using 4.11.0 has reported it is not fixed for him either. See the bottom of: Can't change title bar icon Windows 4.9.1 - Platform & Builds - Epic Developer Community Forums

This issue is currently being handled on: [Icon problem is not fixed - Platform & Builds - Epic Developer Community Forums][1]

Icon problem is not fixed - Platform & Builds - Epic Developer Community Forums