Download

I turned the eye icon off in the outlier, but the object remains visible.

I turned the eye icon off in the outlier, but the object remains visible.

The change is reflected while the editor is stopped, but it is not working while playing.

Is this a bug ?

The version of the editor is : 4.25.1-13594126+++UE4+Release-4.25

No this is the way the UE4 editor works. If I get you right, while editing the level in editor, then the objects are hidden, but when you click play (PIE), then it appears again. Thats how its supposed to work.

Does it mean we can’t turn on or off by outliner during playing ?

I want to check the behavior of level with turning on and off during playing.

Correct.

Editor visibiltity could be seen as an override for rendering visibility. First can be controlled with the outliner, the other can be managed with the component visibility. So look for the “Visible” option under category “rendering” in the details panel. This basically achieves what you ask for. If you change it during edit-time it also is during playing but not the other way around. For that you can right-click an actor and press “Keep simulation changes” while in a PIE.

Dear MaSe87

Thank you for giving me your answer.

I could find “Visible” option under category “rendering” in the details panel, but eye icons do not switch on outliner when I turned visible on and off.
Also, some objects don’t seem to have that item.
Above all, folders in outliner do not have any advanced options.

In addition, “Keep simulation changes” was not found.
I am currently using version : 4.25.1-13594126+++UE4+Release-4.25

The problem is unsolved, but I’ll try to research a little further with your answer as a clue.

The eye is only for working in the editor but does not affect the game
If you want to hide an actor the correct way is “hidden in game”

The visibility option can be found in statistic meshes and skeletal meshes, even so it is recommended to use “hidden in game” and use visibility to work in the editor only