Download

I only used Perforce and added new class... and...

Editor is working fine, but when I compile or build or anything, VS keep say like this

2016-09-10 (1).png

I googled errors, but does not help much.

Why some files in Intermideiate is being denied?

is it because Perforce?

or some kind of glitch that triggered myself?

I have no idea…

I been stay awake to transfer codes from previous project (which being screwed up) to new one by whole night.

I feel hopeless about it. why…

I kinda solve it back up to previous version… Hmmm thx Perforce… for now

edit. not really i think i made it worse by this

d68f6f21c0fe2fdd7939d568b278403161241f1e.png

… hell with it. I will make new project again… bummer

Your issues are due to the fact that any file committed to the perforce repo is automatically set to “read only”, which means you probably committed your intermediate folder. You should remove it from the repo if it is. A quick hack would be to right click your intermediate folder and uncheck read only.

thanks. but i learned it too late. but happy to learn the mistake… :stuck_out_tongue:

Only commit the following folders:

  • Config
  • Content
  • Source
  • MyGame.UProject

Everything else you should generate locally and not submit to the repo.

Binary folder is not safe? Oh my god

Well you can commit that, but if you do make sure you set the files inside to be ‘Always Writeable’ in Perforce, that way programmers can always build without warnings. You can then ‘check out’ binaries and commit them when safe, so that artists / non-programmers can use them.

Commiting .sln files / Visual Studio files makes things… messy. Just have everybody regenerate project files locally if they need them.