I no longer receive crash reports

Since 4.7 I stopped receiving crash reports. Now the engine just hangs and starts allocating memory like crazy, so I have to kill the process from the Task Manager.

Today I made a simple test project using the 4.8 preview where I just access a null variable and I had the same result.

[Here’s my DxDiag][1]

43482-dxdiag.txt (67.9 KB)

Hey ,

Did you obtain UE4 from the Epic Games Launcher or through GitHub? Also, for the new project that you received the same error on, are there any saved files (for example: Unreal Projects\MyProject\Saved)? Are you able to launch ‘CrashReporterClient.exe’ (should be located here: Epic Games\4.8\Engine\Binaries\Win64)?

Looking forward to hearing back from you, thanks!

Hi .

I’m using the binary version from the launcher.

The Saved folder seems to be ok, with the autosave data, the config and the .
[Here’s the latest log from the 4.8 test.][1] Seems like it got stuck at half of the last line.

The CrashReportClient.exe is there and launches just fine.

43487-crashtest.log (16 KB)


Could you provide the from when you run the CrashReporterClient.exe? The three links within your last post are all of the same log, which seems to be cut off.

Also, could you please force your editor to crash? Please open the console and type ‘debug crash’ and it should crash the editor for you. If you do that and a non-responsive message pops up, please check your task bar for any crash reporter window as the non-responsive message appeared on top, while the crash reporter appeared behind all of my windows when I attempted this myself.

Thank you!

I get the same result when I type “debug crash” into the console, the editor freezes completely and I don’t get any message.

Where does the CrashReportClient.exe stores its ?


When you first started the crash reporter missing from the editor, had you tried verifying the version of the engine through the Launcher? If so, did it make any difference for you?

Have you ever relocated UE4 to any other HDD or folder within the same HDD?

Are you able to locate any path similar to these which include saved within them?
C:\Program Files\Unreal Engine\4.8\Engine\Programs\CrashReportClient\Saved\

If all else fails, could you please go to this location: Epic Games\4.8\Engine\Binaries\Win64 and locate ‘UE4Editor.exe’ and launch it? Once it’s launched, could you please try and crash this one as well and see if the crash reporter appears or not?

If you receive a crash reporter or any error , please label them accordingly and upload them to your next response.

Looking forward to hearing back from you!

Hi .

Verifying the engine didn’t help.

I think the first time I installed the engine it was in a different , but it’s been in the same directory since 4.4 or so. And I never relocated it manually if that’s what you mean.

In the CrashReportClient directory I only have a folder named Intermediate.

I get the same result whe I launch UE4Editor.exe manually.

[Here you go.][1] :slight_smile:

43587-appcrash.zip (35.7 KB)

Hey TS,

Could you please enter this into Windows Explorer: C:\Users\YourUserName\AppData\Local\Microsoft\Windows\WER\ReportQueue

Once you navigate to that folder, you should see folders that begin with ‘AppCrash’. Please look for the most recent one and see if the are included there. If they are there, could you please zip the whole folder and send it to us so I can show the information to our developers?

Looking forward to hearing back from you.


Based on the log, we feel this may be the crash that you’re experiencing:
[2015.05.06-18.15.13:752][ 0]LogModuleManager:Warning: ModuleManager: Unable to load module ‘D:/Unreal Engine/4.7/Engine/Plugins/Developer/UObjectPlugin/Binaries/Win64/UE4Editor-UObjectPlugin.dll’ because the file couldn’t be loaded by the OS.

We also noticed that this is for 4.7, not 4.8. We suggest that you should try again on 4.8, and send us the name of the project or machine/Epic ID so that we’re able to locate the latest crash.

Looking forward to hearing back from you! :slight_smile:

The latest AppCrash is from 4.7 because UE doesn’t generates crash reports any more, that’s the whole point. If you look at the date you can see it’s from two weeks ago.
In fact, if you take a look at the Log I attached on my second post, you can see that it has been generated with the 4.8 version.


Hey TS,

I have heard back from the developer and he has requested you to try the following:

We need from this location: C:\Users[YOURUSERNAME]\AppData\Local\CrashReportClient\Saved\

You should be able to run the engine with the following parameters:
“-FORCELOGFLUSH -Log” and then do “debug crash” from the console or
"-FORCELOGFLUSH -Log -execcmds=“debug crash”

He’s requesting the log from the crashed engine and based on that log from the game, and the CRC, he should be able to tell why it’s not working for you.

Also, if the engine is allocating a lot of memory, you should be able to do a minidump during the process, for example:


Looking forward to hearing back from you, thank you for your patience during this process. :slight_smile:

Ok, turns out it actually generates crash reports, it’s just that it takes a really long time, like one minute and a half.
Also for some reason, it doesn’t include my own functions into the call stack so it’s not too useful.

I’m attaching the , and here’s the link for the dump file :


Hey TS,

I have spoken with one of our developers and it’s been requested that I enter some reports for you. So, I’ve entered the following reports for you: UE-16147, UE-16148 and UE-16149

Please keep the log links valid in this AnswerHub post for our developers to obtain unfortunately, some of the provided are extremely large and I’m unable to attach them to the reports. However, I was informed by the developer actively working on this issue that the DMP aren’t needed, since they’ve already been viewed, so if you want to remove that link, you’re more than welcome to.

I will reply back here once I hear more from the developers regarding the crash reporter issue that you’re experiencing.

If you have any updates on your end about the crash reporter working again, or anything of that nature, please keep us updated.

Thank you so much! :slight_smile:

UE 4.8 came out and the issue is still there :frowning:
Any news on this ?

Hey TS,

None of the reports entered have been fixed yet, it’s going to be quite a while until they’re completely resolved. Currently, they are aiming for 4.9 for these bugs to be resolved.

If you have any further questions, please let me know! Have a great one!

Ok, thank you .

You’re very welcome. Let me know if you have any further questions. :slight_smile:

Hey TS,

I wanted to let you know that I’ve gotten word that this issue should be resolved in 4.9. If you’re still experiencing trouble once 4.9 is released (not the preview), please let us know.