I need to deinstall and re-install my graphics drivers every time I restart my PC

Hey guys, I have a very nasty issue with the editor. It doesn’t feel great or particularly stable to go through this process literally every day.

Every time I restart my PC I need to uninstall my graphics drivers (Using DDU) and reinstall them again to properly run the Editor. If I don’t Unreal will freeze up my whole pc instantly as soon as I click any form of geometry or even a blueprint in a list.

It seems like the fresh install always fixes it, as there are no problems afterwards. But as soon as I restart my PC again the freezing issue is present again. Do you guys know what the source of this is? Or maybe I need some specific settings within the NVIDIA Control panel for Unreal to fix this?

I know I’ve got a graphics card that is problematic; I’ve got a GTX 970 and I have 24gb of RAM. My project is 1.5GB in size, so not big at all. Editor Version is 4.16.

I rather not upgrade to a newer version of Unreal as it’s gonna need a lot of work updating the project - but if you guys think this might fix it, I might have no other choice. As you can see, I’ve got no idea what to do. Thanks for the help!

That does sound like your graphics drivers. Can you go back to a more stable version of them?

Hello Googlepaard,

Have you tried the NVidia Studio Drivers? Those are specifically targeted towards production software (Unreal, Maya, Adobe software and others), the latest Game Ready Drivers aren’t always immediately supported by the Unreal Engine and using them can cause issues. Your graphics card, however, should be fine.
Does this problem also occur in other projects as well or is it this specific project only? You could also take a look into the log files of that Project ([Project]/Saved/Logs & [Project]/Saved/Crashes).

Hope that helps.



Hey Vecherka! Thanks for the tip, I never knew about NVidia Studio Drivers. I’m going to check this out, it might just be it.

Otherwise I’m gonna try and revert back to an older driver like ClockworkOcean said - not sure if it will help, but it’s worth a try.

And yes, the problem occurs with any project I open - even blank new templates. It’s not specific to this one project.

Thanks for the help guys, I’ll let you know if any of this worked!

Were you able to fix this issue? I am running into the same problem.