Download

I need help with Make An In App purchase blueprints

Hello

I’m having quite a lot of problems with the Make An In App Purchase. If someone can help me, please I’m desperate.

I’ve looked extensively over the other forum threads, namely where Terrence Burns has answered, but I’m still doing something wrong. There hasn’t been a single thread about In App Purchasing that I haven’t read or tried to emulate. Maybe I’m just not looking at things right.

This is the current state:

I’m running engine version 4.8.3, and this is intended for iOS.

When you press the “Buy Button”, this happens.

Where “Test IAP Success” is merely the addition of coins, and “Test IAP Failure” is just a “Buy fail” message.

The Product ID is the exact same one I’ve registered on iTunes Connect.

The app is not yet published. I have been testing it via packaging the game to iOS as it were for shipping, uploading it to iTunes connect and then downloading it to the device via Testflight app.

From my research, people can use Testflight to test in app purchasing as long as the app is all set up in iTunes Connect, which it is. I also have an account set up for sandbox to use whenever I do manage to get the iTunes store to ask me for a log in.

Basically everytime I click the buy button, it’s ALWAYS a failure, and I don’t know why.

Am I doing something wrong with the Break In app purchase product info?

Can anyone please give me some advice?

Thank you

Do you actually get an object back from your product request that you can split?

Do you mean this node??

Have you set up the contracts in itunes connect? I was only able to get success on the “Free Subscription” in app purchase without doing the contracts.

Yeah I have the contracts all set up and it’s in effect now. Did you use the nodes i’m showing in the picture? If so, how did you handle completion status and the rest of the Break In App Info? I wonder if that’s my problem. Otherwise, do you see anything you might’ve done differently?

I think Completion Status and In-App Purchase Information are just to give you information. I don’t think anything has to be hooked up to those in order for the On Success to fire off.

There must be something I’m missing.

I think the nodes are OK since my Output Log on UE4 says that it can’t complete In App Purchasing because the Online Subsystem doesn’t support it, which makes sense since it’s running on windows. But surely that means it should fire the IAP when it’s inside the iOS. I’ve made double sure that my DefaultEngine.ini has the appropriate lines

but still, it always fails.

I really don’t know what else I can do.

This problem has been SOLVED.

For anyone who has troubles with iOS In App Purchases READ THE FOLLOWING:

Despite what you may find on other threads and documentation, what is REQUIRED is that you ACTIVATE the “ONLINE” part in your iOS project setting. It will activate online subsystem.

THEN, you need to go onto X:\Program Files\Epic Games\4.8\Engine\Config\IOS and open IOSEngine.ini and in there change bSupportsInAppPurchasing=False to =True.

Thanks to everyone who tried to help me.

Awesome, thanks for finding out.