Download

I need help getting the most trivial C++ project started [solved]

I installed MSVS 2017 Community and Unreal Engine 4.17.2 via Epic Launcher as per:
https://docs.unrealengine.com/latest…ion/index.html
I’m trying for a whole day now to create a basic C++ project as instructed in:
https://docs.unrealengine.com/latest…t/1/index.html
I’m getting these errors:

  • ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe
  • Could not edit the code editing IDE. …]\MyProject.sln could not be found
  • MyProject could not be compiled. Try rebuilding from source manually
    I’ve done anything I could read in Answers pertaining my case but nothing worked.
    I can’t open the project in VS. I tried opening from file explorer too but there’s nothing I can do with it.

I mention that in custom components of MSVS 2017 installation I checked (among others) C++ as well; I installed Windows SDK v8.1 and v10 (although I don’t know what these are for but this is how I had to get past other errors).
I can create a new desktop C++ project in VS and work with it very well.

I don’t know what to do anymore. I just want to start Unreal Engine is all. And I don’t want to use blueprints but C++ (basic blueprints works, C++ doesn’t).

Couple of things to consider (can be confusing for sure):

Visual Studio 2017 == version 15
Visual Studio 2015 == version 14

The error you posted is saying ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe

Do you only have VS 2017 installed?

If so, launch editor and in editor setting (NOT project settings) go to Source Code and change to Visual Studio 2017.

Regenerate the vs project files (by right-clicking the .uproject in explorer)

Hope that helps

It looks promising - a big thank you!
I installed VS 2017 without uninstalling 2015 as I’ve read on the internet that it’s OK to have them both.
So, in the editor there were 3 options: Visual Studio, Visual Studio 2015 and Visual Studio 2017
I changed that setting to 2017, sure enough. But it doesn’t make a difference. I’ll find a way to uninstall VS 2015 as now the uninstall button in Windows 10 Apps and Features is greyed out. Strange enough, it reads 271MB and VS 2017 doesn’t show any size :confused:
Any further advise?
EDIT:
“it doesn’t make any difference” = I followed the exact steps you mentioned and it made no difference at all, not even change the 14 in the error.
I’m currently uninstalling VS 2015. For those who want to, you have to press modify and in there you’re gonna find uninstall.
P.S.
Quite a sharp eye you got :slight_smile:

Sorry for double posting but it’s imperative. I can’t even start the engine let alone to start coding. I’m sure that I’m not the only one to be getting through this. Do you guys actually use UE4.17 with MSVS 2017? How?

  • I uninstalled all MS related stuff including VS 2015 and 2017
  • Manually deleted folders like Visual Studio 11, 12 and the rest - there were like 5 although I didn’t have any versions installed other than 2015 and 2017.
  • Launched the editor which now found no compilers so it prompted to install VS **2017 **so it did.
  • Tested but it still popped that error about 32 bit toolchain for v14.
  • Uninstalled UE via Epic launcher.
  • Installed UE via Epic launcher.
  • Tested with the same result.
    Doesn’t anybody have a clue? Any long shot ideas? Please?
    I’m not willing to reinstall Windows though.
    EDIT:
    Is there any config file for the engine to accept a command like

code source = Visual Studio 2017

?

EDIT, ACTUAL ANSWER:
After long noway rewarding research, I found out that UE4Editor.exe accesses some keys in Windows registry to determine the VS versions available. It first searches HKLU\Software\Microsoft\VisualStudio\14.0. There wasn’t such a key on my machine.
Then it looks for* HKLM\SOFTWARE\WOW6432Node\Microsoft\VisualStudio\SxS\VS7.* Here I had to delete some leftovers of MSVS 2015 i.e. 14.0 value. Not the whole key but only 14.0!!
After this I encountered other 2 errors unrelated to VS 2015, that I got past with more search on the internet.

I say it out in the open:
It’s a shame on the companies like Microsoft that are concerned with getting new stuff hastedly without assuring a proper uninstallation so in the end we - the users - after installing/uninstalling software, are encumbered with junk in our PC, that not only hinders the system but makes other correctly conceived software, not functional.

amirea, I have the exact same problem, but I dont quite understand your solution, did you install the keys at the first part, or uninstall? If you did install them, would you mind telling me how, or where to find what you did, I am fairly lost

By “keys” I mean keys in the Windows registry (i.e. addresses). Each key contains value(s) which in turn contain(s) data.
Those keys I talked about and their respective values are installed naturally by VS (or other apps for that matter). When you uninstall the app it should normally remove any trace including registry entries, right? VS has the nasty habit of leaving loose ends - those keys **or **values are an example.
VS 2015 is responsible for installing those particular entries so I had to remove them after uninstalling it.

You’re aware that modifying the registry could break your system, right? And *probably *I wouldn’t do that again if I had to since there’s a better way I found afterwards:
TotalUninstaller. It’s called the same as the famous program but this one’s meant for Visual Studio and you can find it on Github. Use the last version (5 I guess).
Note that if you have VS 2017 already installed, TU will mess it up indiscriminately. So you’ll have to repair VS 2017 afterwards.

Let me know what you’d have done so I assist you further if I’m able to.