I keep getting CUDA error number 2, WHY?

Hello guys, i dont know why im getting this Cuda error 2 when i try to reconstruct the model in high detail. All the photos are align, with a lot of points, so thats not the problem. I have the last drivers installed, and 2 gtx 1080ti cards.

Why im getting this error?

I have the same issue reconstructing normal detail with 62 (12-Mpx) images.

RealityCapture Version RC

Two graphic cards:

GeForce GTX 1060 3GB

GeForce GTX 660

NVIDIA driver version 436.30

Windows 10 Pro 64-bit with 32.0 GB ram

Sometimes I just get an “Unknown error” during reconstruction.


On another project I was able to reconstruct with normal detail, but got “Unknown error CUDA error : 2 : out of memory.” when reconstructing in high detail.


Sometimes after quitting and restarting Reality Capture it will complete the reconstruction.

I have just started getting the same error.  On a new PC with 2 x 2080Ti cards, latest drivers.  Dump log have been submitted.

I’m having this issue now too. Has anyone resolved it yet? I’m unable to process 75 images in ‘normal’ settings with dual 2080ti. Definitely not running out of memory as the error might suggest.

I rolled back the drivers for the GPUs till one worked OK. I went back to June think it was 436.61 but that’s off the top of my head. That’s solved it for me

Thanks for the update Chris! that appears to have resolved the issue for me.

I uninstalled the drivers and used the Windows update drivers.

That fixed it for me too Chris. I think I rolled back to 430.60. Thanks for the post.

had the same problem, rolled back to and it seems quite happy now.