I just bought ue4 and it says "page not found" when i try to download?!

I just bought ue4 and I went to click download, then it loads for a while and gives me a page saying “page not found”. I have tried firefox and chrome and neither work. It is really annoying because I would like to get up and running with ue4 and I can’t at the moment. Can anyone shed light on what i could do to fix it or is it a epic side problem? Anything would be much appreciated!

Greetings Joshisald!

In order to obtain the latest download for the Unreal Engine, please go to http://www.unrealengine.com and log into your account. Once you’ve done that, you’ll be brought to your dashboard. Here, you’ll be able to download the Engine, the links for this are on the right-hand side of the screen under ‘Latest Download’.


If you have any further questions, please feel free to reply!
Have a wonderful day!

Hi ,

Thank you for replying so fast. In reply to your answer I have done those steps and then when I press download, it redirects me to a page that displays ‘Page not found’ and the download never starts. I have tried IE and Firefox as well and the same thing happens?

Hey ,

Do you have any pop-up blockers attached to your web browsers, or installed onto your computer? If so, it’s possible that could be causing the issue you’re experiencing. Double check that and add us to the exception list, if applicable and that should resolve your issue.

If it does not, please clear the cookies and cache from your web browser in case it’s pulling old information and not allowing you to download the Unreal Engine.

I have attempted to download the Unreal Engine for Windows from Chrome and FireFox. Have you given Chrome a try?

Looking forward to hearing from you!