I have no idea why it's happening, but The Blueprint Structure Editor REFUSES to show the "normal pane" to add variables to a data blueprint

I have not tested this under 4.9.0 or 4.9.1 (as I don’t wish to mess them up), so this ocurred with 4.8.3.

I was happily editing a BluePrint Structure (no code, no nothing, just the variables) in what I think of as the standard pane. Where you have the “add variable” button etc.

Now, by “chance” I clicked on the TAB for the Pane, and it just happily closed for me… Well I was happy.


I tried to re-open the same data blueprint, and it refused, or rather, the tab did open, but, it showed nothing, nada, zip, zilch, empty pane.

Tried a different structure/data blueprint, same thing, closed the UE4 Editor, Same thing, closed launcher and editor, same thing, went outside, and howled at the moon, well ok the sun, came back no change, anything I tried, nothing. Started flipping all the Editor config settings, no change, Right click in the “empty” window pane, nothing there. right click on Tab, nothign there, etc. ad nauseum.

So, does anyone know, how to get this darn thing, to open a data only blueprint, such that I can add variables, see the variables that are there, change things, and be happy once more?

Thank you in advance for any and all help!

Ok, don’t know what is going on, still have not figured it out. But created a brand new project, did a migration of the blueprints over, and I still cannot, add any variables, the pane will not open, and I cannot find a way to make it so.

Have also tested under 4.9.0, same thing. I know this has to be simple, so hopefully someone knows what I need to do, in order to alter the Blueprint Structure Editor.

You can (re)open any panel in the Window dropdown menu. For structs, you need to tick Member Variables.


, thank you so much, and screw me running, under my nose all the time.

again, thank you!