I have made several BP's and have received the same message, does anybody know what this means?

"Internal compiler error inside
CreateExecutionSchedule (site 1),
please contact the framework as we
need a report for this bug,"

It has broken several blue prints of mine and I have re-made them, is there another way of fixing this?
I reset my UE4 to see what would happen, now I’m getting a crash everytime I load it.(error below)

The error I get when I now try to open my project is;


We apologize for the inconvenience.
Please send this crash report to help
improve our software.

Thank you.

Branch: 4.4.3 Binary.

Build version: 4.4.3-2296771

Detailed description of the issue:

Here’s a run-down of what happened;
I tested and saved my game yesterday, everything was working fine, when I went back on today I hit “play” to find the my gun wasn’t firing, I went into the blueprints to see that the nodes had somehow disconnected but had left small stubs of blue where the “wire” should be, I dragged them and put them into their correct pins, hit “play” to no avail, I then reset it hoping to just load it again and for it to work, it didn’t, nor did it even load, The entire project crashed and gave me the error below, i can now no longer get into my project without this error crashing it, is there any way I can salvage my project

Screenshots/Link to video: Screenshots would be useless as I just receive an error, will provide if asked for.

Repro Steps

Action 1 Created a system for the inventory, using an int as the inventory value.
Action 2 Created an event so when I clicked ^E^ I equipped the selected weapon.
Action 3 Created another bp actor for the gun and firing mechanics
Action 4 I have a struct to hold all the details of the inventory class weapon including its firing counterpart(the second version with mechanics) so that you can call it, attach it and create an event when i click it traces and spawns an emitter.
Action 5 Got it all working, saved and exited
Action  next day Turned it all back on to find my gun wasn't firing.
Action 7 Looked at the blue print to find that the wires was not connected, there was just blue stubs where the wire was supposed to be.
Action 8 I reconnected the pins, compiled and pressed play.
Action 9 The weapon still did not fire so i reset ue4, not saving.
Action 10 I opened the launcher, went into the library and opened my project, to receive an error. 

System Specs: DXDiag attached.

Attachments: I will send anything you require, just ask me what so I know.

I cant upload the the log files and bmp files, it says wrong format and i can not find CrashReportClient.log in the file you state.

I have found someone with practically the same issue as me; BUG: BP Internal Compiler Error: CreateExecutionSchedule Site 1: contact Framework - Programming & Scripting - Epic Developer Community Forums

Thank you for your report. I have assigned this issue to a member of our support staff, and they will begin investigation as soon as possible. If he is unable to reproduce the issue, or we need additional information, our staff member will comment here with additional questions. Otherwise, we will post an ‘Answer’ once we have logged the issue in our bug database or we have a solution for it.

In the meantime, please be sure to review our suggestions for how to report a bug, and feel free to edit your post if you have additional information to provide.

In the case of a crash like this, please include the Logs, Dumps and a DxDiag.


Hello ,

You have provided a lot of useful information. However, I would still like to try a few things to get a better handle on what may be causing the issue.

Quick questions:

  • Are you able to open other projects?

  • Does this occur on any other projects that you are working on?(If it does and you can get screen shots of the issue please do so)

  • Have you tried this on a clean project? (If not please do so)

I am able to open other projects and this has happened on other projects, it tends to be the Parent class of an actor that this error occurs on;

This is my very first project which I received the error, I created a similar system to the one above that has crashed, it does not work exactly the same but it seems to effect the parent class what I mean by that is,

The original error above was a Actor named BaseGunRef, it had gun firing mechanics with open variables, it then has children derived from it and they would alter the variables to get certain differences (auto-matic, semi-auto etc…) This worked for a while and the parent became corrupt and gave off this error.

The screen shot below is from Usable actor, I followed a tutorial for an inventory system, It says to create an actor named Usable actor and create a child called pickup to have pickup logic and then make children of that to create different types of pickup, it was working, when i saved and restarted this happened;

After this happened I gave up and started the other project which has done the same thing, although this one hasn’t crashed the entire project.

As you can see from the first node in the picture, the wire has a slight color to it, as if the “wire” is still connected but it clearly isn’t, this is what I meant by the blue stubs, although in the original project the stubs where much bigger than the ones in this picture.

Hello ,

After seeing the screen shot I was able to find a report with the TTP# 32422 stating that this is a known issue. Our developers are aware and working on the problem. Thank you very much for your report.

Thank you, do you have any advice for me on what I should do about this? Start again, re-create it ?

Hello ,

There are two ways that I would try out.

Option 1: You can as you said try re-creating the blue prints that you need.

Option 2: You could also try copying and pasting your blueprints into a notepad and saving them as text files. This may be a way you can replace broken blueprints. This will allow you to save the blueprints out side of the engine. Please let me know if this work around is viable for you.

I have done it another way, I just went into the project files saved/backups and replaced the correct assets, the entire project including all the blueprints work flawlessly now, thank you :slight_smile: