I have a failing cast and I am not sure how to fix the problem.

Ok so I am working on the action bar section of my MMO. Right now I have a list of what is on my action bar stored as an object array on the player character.

In this image you can see me grab the array off of character_base point to the index of the array then search for valid references in the list and print them out. This works, it grabs each of valid references and prints out the display name for each actor. So from this I feel like what I want is being stored in the list. However I cant seem to access the list beyond printing the names of the actors within it.

So if I try to cast like this to grab the object so I can reference the image icon and other such information stored in the structure the cast fails. Even though I know the objects in the list are children of Action_base. hmm How can I do this?

You mention that what’s in the “ActionBar” array are children of Action_Base, if it’s some subclass have you tried casting directly to that subclass instead of Action_Base?
Maybe double-check by doing a “Get Class” and print it’s display name for the “ActionBar” contents just to make sure it’s not something weird in there?

I tried to casting directly to a subclass and it had the same result. ill try what you suggest. Really the main thing getting me right now is the failed casting. For example if I just do this.

It works correctly and picks all of the slots that I have an ability equipped and changes the icon to the firebolt icon. This means the main snag I am experiencing is that I cant seem to access the proper information from the subclasses of Action_base.


If the icon is this much of a pain I cant wait for the cooldown timer and proper SP cost. lol

Is it possible that the cast is failing because I am trying to pull information from an actor that is not currently spawned in the world? Because that is exactly what I am doing at the moment. I was hoping that I could pull information off the actual action actor to use for the icons. but everything I try right now seems to fail the cast. and I cant seem to add the actor to an array either. hmm

I guess this means the Icon will have to be its own thing with duplicate information… damnit.