I found out that in order to move/copy Blueprint assets from one project to another, you need to Migrate, not Export

I was very confused why Unreal Engine could not import the file extension that it had me export my scripts as (.COPY) until I spent some time to do some digging and found this old thread from 2015 explaining that that was a legacy feature from UE3:

Why is the option to export those as .copy files still in Unreal Engine 5? :((

1 Like

Migrate and export are a different thing:

  • Export is useful for many file types (meshes, textures, et cetera) because it allows you to convert them to a format readable outside UE (because .uasset file can’t be opened with other SW)
  • Migrate does a very different thing: it looks for references in the file you are trying to migrate and asks you if you want to migrate them too to a new project (and you have to select the content folder of the other project because .uassets files use relative paths (if you move them from windows instead of the content browser they won’t work)

If you move a blueprint you probably don’t want to export it (because it’s almost sure that it contains external references), the export to .copy has been left for legacy compatibility.

Maybe I’m lucky but I learned about the “migrate” in the first UE video I’ve ever saw so I’ve never had your problem, but I admit that “export” is the first word I would look for to achieve something like that


Export was listed first, so I tried it first, and Unreal Engine allowed me to export the files… so I didn’t at all feel like I was doing it wrong until it didn’t work and I had to go digging for a solution.

I’m sure Export is very useful for certain things, and I do appreciate you sharing more info, but I also do feel like the engine should have prevented me from doing an export of things that it did not support an import for.

Or at the very least give a warning so that users don’t waste time choosing what blueprints to export, only to find that they aren’t allowed to import them…

Unfortunately that’s not how it works, it should, but it doesn’t.

Every software is different and you can’t really expect it to do something “standard”, and sometimes updates changes stuff that “has Always been like that” (Yes, I’m talking about you, Photoshop).
The first thing I did with Unreal was to take a generic course (and it saved me a lot of swearing), you can’t just open a software and hope that it’s intuitive (I wonder which drugs UI/UX designers use in some companies).

Here’s a few examples to explain why I don’t have any expectation anymore:

  • Try to open Zbrush and nothing is where you would expect it, I still struggle to remember how to navigate/move the object (or the fact that if you want to export an .fbx you need to use a plugin). Blender is not much different (if you don’t know the shortcuts good luck using it)

  • Unity is not much better than Unreal in terms of hidden things (I find its interface very unintuitive), I had to install a paid addon to extract a 3D model from a project :sweat_smile:

  • Photoshop changed the “undo” command after 20 years (and now there’s an option called “use legacy”), and did the same with the “Save as” menu, now you can’t save anymore as .JPG or .PNG, you need to “export” unless you change the shortcut to legacy (and I could list many other problems since I’ve been using it for like 18 years)

  • These are the defaul Autodesk Inventor 2022 commands:
    If you don’t change them, you can’t rotate the viewport with your mouse (I wasted like ten minutes trying all the keys because I was sure that it was working in the past)

I hope I haven’t bored you, I just wanted to share some of my frustration with you and tell you that I understand yours :rofl:


Remember when they broke TGA alpha channel export and were super surprised that anyone would use the alpha channel of a TGA in the way that EVERY GAME DEVELOPER used it at the time?

… something something shoemaker’s children go barefoot something something …


Why on earth does Autodesk have all that set to Pan and not any to Rotate… smh.

On the topic of Unreal, I do want to say, I didn’t just open it and hope it to be intuitive; I’ve been dabbling with the engine for almost a year now and I’ve watched and read a lot of tutorials. Today was just the first time I tried to move something between projects.

The only thing I was expecting was for “Import” to work on the assets I had clicked “Export” on. :stuck_out_tongue: