I didn't can set collision in blueprint

Hi, I can not put collisions on my cube that is in a character. Is there a way to do this?
PS : I’m French so my English is verry bad.

I use the default cube, I have attached the parameters of the cube. Thank you for your help.


uhhhhh look at your collision preset there. now theres your problem you have the collision set to noCollision. you want it to be able to block things aka collide, for this to happen you need the collision preset to something other than no collision. try clicking the arrow next to where it says collision presets this will open up the full menu, then set the preset to custom. this will allow you to set the collision response to each channel individually. in this way you can decide if you want your cube to: ignore - do nothing, overlap - things can pass through but the overlap events fire, or block - the other object wont pass through.

does the mesh itself have simple collision? to check; open the cube mesh by double clicking it, then click the collision button near the top, then click simple collision. this will show you the collision in the viewport (its in green i think). if your using the cube built into the engine then it already has collision and you probably have the collision presets set wrong.

show us a image of your setup and the current collision settings. also what are you attempting to collide with? it could be that the other object has no collision response (block) to the cubes channel.

Sorry but it’s not working… I can not put this collision! Maybe the fact that it has a capsule component already has a collision produces confusion? What easy solution is possible? thank you in advance