I Can't Update My 4.16.1 Engine To 4.16.2

You try restarting the Epic Launcher? Or your computer? There should be an asterisk on Engine Version in the Epic Launcher.

Hey, i cant update, my engine to the latest version (non-snapshot)
and i really need the answer because each time i want to copy and paste something it crashes and ive heard that the new engine version (4.16.2) has fixed it so it would be incredibly usefull if i could simply know the answer to how to update it because apparently it can’t auto update also i dont find any button or message saying there is a newer version of the engine like if it would ignore it :I

well its fixed now i had to verify myself the cache setup throught 3rd party programs that can check ram and prossessing basicly there where no more like finder for updates thats just weird but i fixed it but your technique wouldn’t work anyways because i got that problem since like 4.16.2 released I couldn’t update and ■■■■ but thanks anyways ^^

also simpler way for poeple with same problem just click on your engine click verify does everything i just said but its simpler i just did it manually ^^