Download

I can't paint without crashing?

When opening Unreal Engine 4.9.

I clicked the Landscape Mode.

Changed Material to M_Ground_Grass (Preset in UE4).

Section Size: 63x63 Quads

Sections Per Component: 1x1 Section

Number of Components: 16x16

Overall Resolution: 1009x1009

Clicked the “Create” button.

Clicked the “Build” button (to get rid of those squares on the landscapes).

Once done, while in the Landscape Mode. Clicked Paint. Change the Circle to Pattern.

And it crashed.


Unknown exception - code 00000001 (first/second chance not available)

"Assertion failed: (uint32)BlendMode < NumBSS [File:d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\engine\public\BatchedElements.h] [Line: 307] "

UE4Editor_Core!FDebug::AssertFailed() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\misc\outputdevice.cpp:354] UE4Editor_Engine!FBatchedElements::FSimpleElementBSSContainer::GetBSS() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\engine\public\batchedelements.h:308] UE4Editor_Engine!FBatchedElements::PrepareShaders() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\engine\private\batchedelements.cpp:661] UE4Editor_Engine!FBatchedElements::Draw() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\engine\private\batchedelements.cpp:1063] UE4Editor_Engine!`FCanvasBatchedElementRenderItem::Render_GameThread'::`8'::EURCMacro_BatchedDrawCommand::DoTask() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\engine\private\userinterface\canvas.cpp:469] UE4Editor_Engine!TGraphTask<`FCanvasBatchedElementRenderItem::Render_GameThread'::`8'::EURCMacro_BatchedDrawCommand>::ExecuteTask() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\public\async	askgraphinterfaces.h:779] UE4Editor_Core!FTaskThread::ProcessTasks() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\async	askgraph.cpp:539] UE4Editor_Core!FTaskThread::ProcessTasksUntilQuit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\async	askgraph.cpp:340] UE4Editor_RenderCore!RenderingThreadMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\rendercore\private\renderingthread.cpp:310] UE4Editor_RenderCore!FRenderingThread::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\rendercore\private\renderingthread.cpp:411] UE4Editor_Core!FRunnableThreadWin::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:74]

Can anyone help me figure out why it’s doing that?

  1. report this on answerhub -> https://answers.unrealengine.com/
  2. also keep in mind that you cant paint onto a landscape when you dont use a landscape material!!! https://docs.unrealengine.com/latest/INT/Engine/Landscape/QuickStart/4/index.html :wink:

Ah thanks! Just learning how it work. :stuck_out_tongue:

The missing landscape material is surely crashing the engine -> that shouldnt happen, so would be good if you could report this on answerhub so that epic games can track it more easily :slight_smile:

Already done! It’s an annoying bug but it would be fixed in the next update! :slight_smile: