I can't Open My Unreal Engine Projectsg

When I try to open my project, it will send me some errors.
Here… What can I do now??

Fatal error: [File:D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp] [Line: 221] Ran out of memory allocating 2884648946 bytes with alignment 2. Last error msg: The paging file is too small for this operation to complete…

UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_CoreUObject
UnrealEditor_CoreUObject
UnrealEditor_AssetRegistry
UnrealEditor_AssetRegistry
UnrealEditor_AssetRegistry
UnrealEditor_AssetRegistry
UnrealEditor_AssetRegistry
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
kernel32
ntdll

1 Like

Well, it looks like you’ve run out of page file.

Things to look at:

  1. Reboot

  2. Don’t run anything else

  3. How much RAM do you have? Typically the page file is 1.5 times your RAM. Here, its looking for about 3GB.

  4. Are you running out of disk space?

2 Likes

I have 32GB Ram + Rx 580 8GB GPU
Also, Have 35GB of Storage Left On My SSD

1 Like

Can you help me with this ??

I think the error is the best thing to go with for now. How large is your paging file? ( methods vary with just about every version of windows ).

I don’t have any idea about paging file. Where can i see it ??

This article tells you how to change the page file size. Keep a note, in case you need to change it back

1 Like

Oh, I already changed it. Still same issue.

Reboot after change?

Yes.

On Which drive should I change parge ??

I think it’s only on the system drive?..

My project file is in one of my SSD drive.
But i don’t know which drive purge i should change!

Also what is Fatal error: [File:D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp]
I tried find the file from this location, but this D:\build file is not in D Drive

I have seen some stuff about unreal crashing because of D: being accidentally compile into the engine somewhere. I’m afraid you’ll have to rummage around for that one yourself…

Also try disabling megascans.

Can you explain to me about the rummage?
Why do I need to do that and how ??
Sorry for asking too many questions, actually I’m a beginner.

Just google around, if you put ue4… you will end up on this forum.

There are questions ( and some successful answers ) about D: appearing in compiler errors, when people do not have a D drive.

One thing to do is to make sure you have debug symbols enabled. This will give more information when the engine crashes.

To do that, simply:

  • Open the Epic Games Launcher
  • Click on the drop down arrow next to Unreal Engine 5.0
  • Select Options
  • Find ‘Debug Symbols’, enable it and let it install

Part of the issue here might be the low SSD space. It’s very possible a cache is being stored somewhere (or the project itself) which is running out of space and causing the crash.

I would advise cleaning some space off of your SSD as it’ll help your overall PCs performance since Windows really dislikes low storage space. Hope that helps a little! :slight_smile:

2 Likes

I just got the same error and fixed it by enabling the “Automatically manage Paging File size for all drives” option on the Virtual Memory settings. If you can’t find it you can follow this tutorial to get to it: How to Change the Windows Pagefile Size – MCCI

2 Likes

Thank you so much it worked for me, I had an issue where after updating to new SSD(SATA clone) i was unable to render any of my old projects( crash out of memory error). after following the steps above i as able to resolve my issue.
instead of manually entering the memory for each drive i have set it to “system managed size” for all my drives. :slight_smile: it worked for me

2 Likes