Download

I can't open my project anymore

Hi. Yesterday I’ve finished working on my project, closed it and also saved a backup ( I do this once a week ) and today when I wanted to open the project again it doesn’t work anymore. An error is thrown. How can I solve this? Even the backup doesn’t work, only a week ago, so there are a lot of changes I’ve done to my project.
This is the error when I open the project. I’m working with engine version 4.22 V3
Thank you!

Edit: I think the problem is related to my other problem Events triggered twice in Level BP - Unreal Engine Forums
Because this level with problems is my editor start up map and after I changed it in DefaultEngine.ini into another map I can start the project but I can’t open anymore the level.

Hi Paul, you should be able to open the project once you changed the startup map. The map load crash of the edited map is likely related to some blueprint code. Can you remember what kind of blueprint you edited? Try first to rename said blueprint or blueprints, or move them into a temp folder to check if the map loads once again. If you be more specific what kind of bp edits you’ve done I may give more accurate pointers. Also you may get an idea of what bp is the issue when looking at the crash log inside your saved folder.

Do not open your project, copy all autosave files somewhere else. Try to open them in editor (copies!), there is chance that some of them has uncorrupted map. Unless you already tried to open corrupted project too many times, and it overwrote last working autosave.

And do backups daily!

You shouldn’t be doing any serious projects with a Preview version tbh… this kind of things always happens with preview versions, always something break, always something leaves projects unusable.

For a hint on opening your project, try to edit DefaultEngine.ini and locate the setting EditorStartupMap and make =None. It might be that only the default editor map is corrupted. Also, delete the Intermediate folders before opening the project.

Hi. Thank you for your reply. Yes, now I can open the project after I changed the startup map. Yesterday the last thing I’ve done, was working on a slider inside a widget to change the background volume and inside Level BP ( where I control the background music ). I didn’t worked at any other bp actors.

I will try your solution with an older backup. I will do daily backups from now on.

Hi. Up I’ve edited the post and I was telling that I think this problem is related to my other problem. The project was created first in 4.21 and from there the problems started. It was to late to re-create the project again because it was a 4 months work. Now I’m working on 4.22 and I didn’t had any problems. I’m using this version because I can use the spotlight as a flashlight for mobiles…
I’ve also deleted intermediate and saved folder but without any succes.

What I’ve done now. I edited defaulgengine and set up another startup map and I can now open the project. But if I want to change the level ( where all my work is ) it crashes. I also can’t delete any assets from some persistent levels. It also crashes.

Thank you all!

Edit. Yesterday after I closed the project I did a backup. But it seems that even the backup doesn’t work. I did with with crash I think. As I remember, without any reason when the files were copying there was an “error” that a file from intermediate folder is missing and can’t copy it so I skipped that, because as I know those files can be deleted from your project.

Don’t forget to submit the crash report when the screen appears, it greatly helps the devs to find the issue. Keep that copy from you project because there are issues being fixed for crashes in the Preview 4 which might be out next week. You can also copy here your logs when the editor crashes for us to see.

Usually I don’t touch the backups. I copy it into another folder and open it from there. I always send the crash reports to Epic.
I uploaded the crash report.
Thank you!

I’ve had a lot of corrupted project issues but they seem to resolve themselves by dragging the contents folder into a new project and rolling with that.

Thank you very much. Is working! First I’ve created a new project with the engine version 4.22 and it didn’t worked, but after I’ve created a new project with 4.21 and dragged the content folder, my project works again.

Still doesn’t work. Thank you for your response!

The problem here may be that the culrpit is located in the level bp. Hence, try this (try to break the connections), rename the level map, then try to load it. Or try to rename the widget first.

I tried to rename the ‘level_1’ from content folder into ‘firstlevel’, but after I open the project, I still have level_1, not firstlevel.

Try this, Copy the map (rename it), then open the copy, if it fails, remove that widget you were working on too.

Hi. I succeeded to found some workarounds. First I renamed the level_1 into firstlevel but I can’t find it in content browser. After that I deleted all the files from content folder and I left only /levels/ folder and I succeeded to find the firstlevel after searching inside content browser ( Still my file was written as level_1 ) and I also succeeded to open the level, but of course was empty. Only my level bp is there. So now I’m trying to delete each file and open the project to see where is the exact problem. I’ll come back with a solution. Thank you very much!
Edit: After removing each file in part I succeeded to find the problem. It was another file which I didn’t touch a while but without any reason that was the problem. It was the Hud Widget where I have all the stats/buttons for settings and more which was loaded on event begin. I’ve created another widget, copied all the assets and deleted the old one and now it works.
Thank you very much to all for your help :slight_smile: You are great.