Download

I can't make In-App purchases working?

I’ve tried so many times, but it’s still not working. I don’t think there’s a problem with my BP, but when I publish my app in alpha testing and when I download the app and click the “Remove ads button” which will run the In-App purchase. All it does is sign into google and that’s it. I have In-App products setup in my google play dev console and I put the name of my In-App product in the UE4 project settings. I followed this link for the instructions on In-App purchases.

This is my Bp of the In-App purchases

4390f5c00d0329eaa3442c0f08d263ce50805631.png

I’d recommend you to have a look on the Match 3 IAP example.

By the way, the way you setup your IAP to hide Ad banner is wrong. The ‘Force Close Ad Banner’ node will reset when the app restarted/re-opened again, thus will show all the ingame Ads again.

So, as a user of your app, I’ll need to do the IAP again and again just to remove the Ads, which is bad.

Again, have a look on the Match 3 IAP example.

Ya i know. i only put that forse close ad node to make sure the in game purchase actually works in the first place. Ill look into match 3

Hi,
Verify if your IAP identifier is correct.
Verify if your IAP is Active on Developer Console.
IAP only works if you download your beta app from Play Store, IAP don’t work if you Lunch to your device from editor.

Verify in UE Editor - Project Settings - Platform - Android , if you Activate Play Services and set the correct Games App ID and Google Play License Key.

The IAP is correct, its active on tge google dev console, i did download it from the play store from beta testing and i didnt launch it through the editor. I’ll double check but I’m sure I did everything right yet it’s still not working. Which is why I came here.

Verify in UE Editor - Project Settings - Platform - Android , if you Activate Play Services and set the correct Games App ID and Google Play License Key.

I had problems in the begginng with Games App ID, it is a number with 12 digits

Yes the google play license key and games app id are correct. Otherwise the achievements, leader boards, and google play games sign in wouldn’t work in the first place. However, they do so I would think that In-App purchase would work to but it doesn’t. Also the games app id isn’t 12 digits it’s 11. Or am I missing something?

OK, if achievements are working than all is set right.
My ID has 12, but probably the number is growing…

What UE Version are you using? Because there was a bug in 4.9 : https://answers.unrealengine.com/questions/332179/make-an-in-app-purchase-node-does-not-work-correct.html

4.10.4, does this ver have the fix?

Yes. I am using also 4.10.4, my IAP works fine

Then can you mind letting me see your In App purchases BP? Because there’s obviously something wrong with my BP becasue tgis isn’t working. If I can’t figure this out then I just cant add In app purchasing to my app

I call “log in UI” only once when the app starts (IAP0.JPG) Not every time the user tries to buy something
Than i use “Make in App Purchase” When user click on an store item to buy it (IAP1.JPG)

This is my app if you wanna try the IAP : Sign in - Google Accounts


I’m at school right now but when i come home I’ll try and work around my Bp, but as you can see you can’t find any error in my bp? Also nice app!

Ok. Thanks. I cant see any error on your BP. Maybe is something like: the “Product Identifier” doesnt like the character “_” , or because you didnt connect the “Exec” pin on “Make an In-App Purchase” object. I dont know, sorry.

Can anyone tell me where to download the match 3 example? I found only the game on play store. But isn’t there a project file with blueprints to download to see how it is build in the engine? Would be nice if anyone knows.

It’s in the store category in the UE4 launcher

You can find it both in:

Learn Tab -> Example Game Project
or
Vault Tab by default installation

Well i found it. Thanks for that.

But now the problem. It seems i have the same problem as spookey0188 as he wrote this thread. My blueprint looks nearly similar as in his second photo (post #12 on this thread). I press a button, than it shows login ui. If sucess it makes an in app purchase and if this is sucessfull it calls a function that handles the other stuff (for example adding coins to the actual coins). But when i test it after downloading from play store (beta test) it only shows me a logging ui. There happens nothing more. And yes i set the in app products in the developer console and added my licence key and everything. Showing in add banners works fine too. Just in app purchases not. I also checked the match 3 example and it seems similar too. Maybe spookey0188 solved his problem and know how to figure it out? Or someone other? Would be nice from you!

Hi Leolyn,

Did you add the primary account on the device to the test accounts list on the dashboard and authorize it for beta testing for the APK? You also have to accept the beta invite for in-app purchase testing to work.

How do you do that? Where do you add people to access in-app purchasing. If your talking about this then yes I already have done it and still doesn’t work.