I can't install any engine version

Hi Team,
I have installed Epic Game launcher on my 2 Macs and Windows.
On Mac with intel graphic I can install any Engine version I want, so I installed and removed them. Same with Mac with NVIDIA GPU.
My Windows machine has NVIDIA too, however I can not install any Engine version, the + button is grayed out. (Attached)

Pretty annoying that my powerful Windows machine is not able to do so. I have updated my NVIDIA driver.
It is NVIDIA GForce RTX 2080.

Please help me to. Thanks. I also tried to run it as administartor, same thing. I check the security and everyone has full access. Not sure whatelse I can do.

You’ll want to get the source build version anyway.

instructions: Unreal Engine 4 on GitHub - Unreal Engine

There are plenty of resources on how to get that done including the instructions on the Unreal Engine GitHub (make sure you sign into GitHub).


Also, make sure you have visual studio installed.

My system would way pass the min requirements.
Also I have installed and uninstalled it twice. and any trace of Epic on my machine. still the same issue.

I’ve never run into this issue before. Your system meets all the min specs? You’ve got enough HD space etc? If the button to add them is greyed out, I’d suggest uninstalling and re-installing the Epic Launcher. Also, make sure you’re logged in maybe?

Maybe this Downloading Unreal Engine Source Code | Unreal Engine Documentation is my only option

Try making sure you’ve got the MSVC++ Redistributables installed:

That fixed an issue I had with the launcher years ago. Shot in the dark, but it might help you now.

I have installed MSVC++ 2019 still the same. Still I can’t install any engine

yes i have the same problem epic please fix this issue

yes i have the same problem epic please fix this issue

I have fixed it, I installed the MSVS 2019, then all of missing packages. That fixed it.