I can't get Unreal 4 to install

I’m running Windows 7 and I can’t get Unreal 4 to install.
It gives me an error: “There is a problem with your Windows Install Package.” right when it hits Installing DirectX.
Any help would be awesome!
Best,
-Bill
Owner/ Awaken Games

Hi ZCoolUnreal,

Sorry to hear that you have hit an issue. There is a log that we would like to see that might provide some helpful information. To generate it, please do the following:

  • Place the msi on the root of C drive
  • WindowsKey+R and enter:
  • msiexec /i C:\UnrealEngineInstaller.msi /L*V C:\UnrealEngineInstallerLog.txt
  • Replacing “UnrealEngineInstaller.msi” with the actual msi filename

Then please upload the log here and we will take a look.

Thanks

The Log is too long to post here, can I email it to you? Just contact me at Will@AwakenGames.com

Perhaps you could zip up the log file and then post it.

Here you go

According to your log, DirectX install is failing with error code -9. I did a bit of searching and it appears that the -9 error code for DXSetup.exe happens in two known cases. Perhaps you could check this out and see if the solution they specify on the Microsoft support page works: http://support.microsoft.com/kb/177430

You can also try to install the DirectX End-User Runtimes from here to see if you get any more detailed info on why it is failing: http://www.microsoft.com/en-us/download/details.aspx?id=8109

If you are still stuck, you can try the following workaround which will disable the Unreal Engine installer’s DirectX setup.

  1. Manually download and install DirectX from here(DO NOT SKIP THIS STEP): Link

  2. Download the latest Unreal Engine Installer

  3. Run the installer using the following commandline(replace C:\UnrealEngineInstaller.msi with the path and name of your downloaded installer):

    msiexec /i “C:\UnrealEngineInstaller.msi” SKIP_DIRECTX=“1”

I did a re-install DirectX with no issues. The stop point seems to be:

CustomActionSchedule(Action=InstallDirectX,ActionType=3090,Source=E:\Unreal4\Unreal Engine\DirectXRedist\DXSETUP.exe,Target=/silent,)

CustomAction InstallDirectX returned actual error code -9 (note this may not be 100% accurate if translation happened inside sandbox)

So the question is, what is Unreal’s install doing with ActionType 3090? Once I know this I can backtrack to the issue.

At that point, the UE4 installer has extracted files to the install folder and it is trying to run the DirectX End-User Runtimes installer (DXSETUP.exe). From the line you posted, we can see that in your case E:\Unreal4\Unreal Engine\DirectXRedist\DXSETUP.exe was extracted from the UE4 installer and that it is being executed with the /silent flag. I’m unsure why it would fail and the manual DirectX install you attempted succeeded. The DirectX installer we ship contains a subset of files from the download page I pointed you to.

You did mention that you did a re-install of DirectX. Can you elaborate? Do you mean that you selected the repair option?

Also, I didn’t get a chance to investigate the potential fix on the Microsoft support page yet, was that not useful?

On MS web site they say to:
1: Find “dsetup16.dll” and “dsetup32.dll” and rename to “dsetup32.dxx” and “dsetup32.dxx”
2: Reinstall DirectX again.

So that is what I did, but no luck.

A friend said it might be my Video Card, which is an GeForce 250. While I might see this being the case once Unreal4 runs, I can’t see why that would stop an install. Would it?

Another friend said I should install “Orcs Must Die” and test that to see if it would work, and it installed DirectX 11 as part of the game and it runs just fine.

???

Try changing your install directory from the default to C:\UnrealEngine4\

Thats my solution to you because I suspect your using Windows 8, unlike these other jokers, I don’t need a log file to tell you how to fix your problem, =D

It appears that he was already using E:\Unreal4 which is not the default path and running on Windows 7 with Service Pack 1 (SP1). Log: VersionNT = 601, WindowsBuild = 7601, ServicePackLevel = 1

Did you encounter an issue where the default target install path was causing the installer to fail?

Quick update: Though there is still no workaround for this issue, some changes were made to the installer that will allow you to get past this issue. Those changes will be available in the next launcher release. Once that is available I’ll update this thread with more info.

I have tried installing UDK several times - I just subscribed. Nothing happens - I see it loaded under programs, but will not fire-up. It will not completely download.

thanks,
julian
jlnsvfx@gmail.com

Hi Julian,

You are reporting an issue that is different from the other people here. Please make a new post that is specific to your issue. Before you do, however, please review the information on this page:

A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

See if any of the solutions help you. And be sure to provide your verbose logs in the new post if not.

Thanks