I cant get my Ai zombie to navigate towards my players house, as its primary objective. I've linked an image of what ive done so far

Also when I put my cursor over controller it says “Controller reference current value none”, I am not sure why this happened, I did exactly how I saw on a tutorial video related to it.

Sorry, question is can someone please help me figure out how I can get my zombie Ai to navigate to my players house please?

Well, for one, you have a ton of Press Z events, which can’t be good. Aside from that, you are also missing the Cast To Actor nodes that would actually send the commands to the zombies. All of that said, there is a better way!

  • Select the Zombie actor in your SceneOutliner
  • Open your Level BP
  • In your Level BP, create an Event Dispatcher called SendZToPhouse(or whatever you want).
  • Drag the Event Dispatcher off the My Blueprint to the Level BP Event graph and Assign a new event.
  • Right Click and add a reference to your Zombie Object
  • Drag off the output pin to make a Cast To node
  • Wire that in with whatever movement instructions you want.
  • Open your Character BP.
  • Where you have the Press Z event, Delete all of that and make a call to the Zombie’s event dispatcher.

Thanks for your assistance. However when I tried to find a “cast to” node it doesn’t appear. There is “cast to player controller” or directs me to “to Transform”. Then I looked for Move to and there was " move to location" etc.
Is this process still ok for a 2D game?

You may need to go to Edit>Editor Preferences>Experimental and toggle on the experimental context menu check box

NOTE There are some bugs with this thing. If something you expect to show up doesn’t, try toggling it the other way. I know some events won’t show up if it is toggled off, and casting won’t show if it is toggled on. Some of this was fixed in 4.51, others will be fixed in the next update.

Yeah I have set an AiController. Well when I check out a tut video about this, It said to use a NavMesh Bounds volume, but I feel it may have not worked properly as I could not see anything green like it showed and mention in the tut.
Yeah thank you I will most likely be using that, thank you.

Yeah I have tried to find a way to fix it but I don’t think it works properly for 2D game.

So here is where I have added a NavMesh but it only shows a yellow square outline that fits the map size but I don’t see anything green as to where the zombies can move around to. Any suggestions that might help me fix this please? The tut video wasn’t too helpful on that end. Thank you for your help guys.

Did you set an AiController in the defaultstab of the Zombie Blueprint? Also do you have a proper navmesh?

You also don’t have to move every zombie on its own. You can get all of them with “Get all actors from class” that returns an array that can be used with a for each loop to move every zombie at once.

Ok first try to fix the navmesh. That could fix it.