I can't get a basic login functionality to work in UE5 and it's driving me crazy

Hi you all, I really hope someone is able to help me here. I’m trying to get the most basic multiplayer functionality to work in UE5 using EOS: I just want one player to host a session, and another player to join that session using EOS and blueprints. Somehow, that doesn’t work for me. I’ve googled up every combination of the problem I can’t think of. For the first time in years, I don’t know what else to try or what else to look up on google. I’ll tell you what happens and what I’ve tried:

What happens is that the session is, apparently, created just fine, but when I try to join it, the game prints “joining successful” but instead of opening the game level, it just gets me back to the main menu again. This doesn’t happen when I check the “Use LAN” checkbox in both Create Advanced Session and Find Sessions Advanced (I’m using the Advanced sessions plugin) and play on the same computer, but when I uncheck it, it doesn’t join the match properly. It doesn’t matter If I try opening two stand-alone games in the same editor (net mode: play standalone) or if I open the packaged game in two separate computers.

As to what I’ve tried, first of all I followed this tutorial which means I’ve created a product at Epic’s developer portal, assigned a client with a peer to peer policy, I’ve configured both permissions and linked clients, copied all the relevant IDs and pasted them on the OSS plugin settings page and added the relevant lines to DefaultEngine.ini.

The login functionality is summarized in the following pictures:



Also these are the multiplayer and OSS settings:


I’ve also googled the issue painstakingly. Some people say this might happen if I have non-english characters in my system’s name, which I don’t have. One guy said the EOS Online Subsytem (OSS) Plugin needs an extra line added to the DefaultEngine.ini for UE5 that doesn’t appear in the documentation page (it’s not updated for UE5), but he doesn’t say what line is that and I cannot find anything about it. I’ve looked at my logs. I’ve seen a couple lines which seem relevant, but I cannot find anything useful about them. Those lines are:

[ 47]LogSockets: Warning: GetAddressInfo failed to resolve host with error SE_HOST_NOT_FOUND [11001]

and

[ 48]LogNet: Error: UEngine::BroadcastNetworkFailure: FailureType = PendingConnectionFailure, ErrorString = Your connection to the host has been lost., Driver = PendingNetDriver NetDriverEOS_0

I’ll also attach the logs.
MultiplayerEOS.log (185.2 KB)
MultiplayerEOS_2.log (131.0 KB)
MultiplayerEOS_3.log (124.6 KB)

But that’s it. I have no idea about making multiplayer games in UE5, and when the most basic stuff fails, there is only so much that I can do without help. I’ve been trying to fix this for 3 days now, but sill no luck.

Thanks.

Any ideas? I’m using the advanced sessions plugin, I don’t know if it can be culprit of all of this

Hi. I’m updating this with more info, I hope someone can eventually help me.

A friend of mine followed the same tutorial and created a simple game with a basic host/join feature too. Here’s what we’ve found out:
-His game works on both his and my computer.
-My game works on his computer but, as I already said, I doesn’t work on mine.
-Both his game and mine works regardless of whom EOS credentials we use.

So, theoretically, the problem’s not on my computer (his game works), neither is on the tutorial, UE5 or advanced sessions 5 (again, his game works), nor it is on EOS’s credentials or configuration (both our games work on his computer). Is also not on my game (works on his computer) nor in my network (his game works). The problem is nowhere, it seems. Still I can’t get it to work.

Given that the tutorial was focused on UE4 and a certain modified version of Advanced Sessions, I followed it again using these versions. The result: the exact same error.

In the log of the server I’ve seen the following line:
LogEOSSDK: Error: LogEOSSessions: Invalid parameter EOS_Sessions_RegisterPlayersOptions.SessionName reason: cannot be null or empty

And in the log of the client, the following one:
LogNet: Error: UEngine::BroadcastNetworkFailure: FailureType = ConnectionTimeout, ErrorString = UNetConnection::Tick: Connection TIMED OUT. Closing connection.. Elapsed: 20.00, Real: 20.00, Good: 20.00, DriverTime: 20.00, Threshold: 20.00, [UNetConnection] RemoteAddr: 212.225.139.165:7777, Name: IpConnection_0, Driver: PendingNetDriver NetDriverEOS_0, IsServer: NO, PC: NULL, Owner: NULL, UniqueId: INVALID, Driver = PendingNetDriver NetDriverEOS_0

I’ve tried increasing the timeout in DefaultEngine.ini adding the following lines:

[/Script/OnlineSubsystemUtils.IpNetDriver]
ConnectionTimeout=60.0

but to no avail.

It works now. It was all a networking issue. I’m not sure if the problem was the ports or the DNS server (I changed both at the same time) but one of them is. I’m also not sure why my friend’s game worked on my computer, or why my game didn’t work on the PCs of my office either (I supose there’s the same networking issue there by pure coincidence), but in any case it just works now.

I’m going to link Epic’s online connection issues troubleshoot page here, for further reference.

1 Like