I cannot launch my project on Mac OSX

Unreal Engine 4.9.2 - Mac 10.10.4

I click the “Launch” button and it starts to launch my project but then it crashes. The crash report log file contains the following:

[2015.10.28-02.11.37:381][ 0]LogMaterial:Error: The global shader cache file >‘/Users/Shared/UnrealEngine/4.9/Engine/GlobalShaderCache-GLSL_150_MAC.bin’ is missing.

Your application is built to load COOKED content. No COOKED content was found; This usually means you did not cook content for this build.
It also may indicate missing cooked data for a shader platform(e.g., OpenGL under Windows): Make sure your platform’s packaging settings include this Targeted RHI.

Alternatively build and run the UNCOOKED version instead.

  1. In the “Launch” dropdown I choose “Project Launcher …” and check “Advanced”.
  2. I choose Variant=MacNoEditor, Config=Development, Data Build=Do not cook
  3. In XCode I choose Scheme=MyProject - Mac, Destination=My Mac
  4. In Edit → Project Settings I choose Build Configuration=DebugGame

In all my Googling and brute-force searching these are the settings I have found. It used to Launch fine but now it doesn’t and I haven’t changed these settings. There is a similar question link:HERE but it hasn’t been answered since June except to throw the “Read the Manual” answer.

link:FROM THE MANUAL comes the following helpful text:

When running the binary Editor, it is important to add the -game flag if you rebuilt your project in any Uncooked configuration, and the -debug flag if you rebuilt your project in any Debug configuration.

which doesn’t actually say where to add these flags.

Hello ,

I tried reproducing the problem by following your steps but everything worked fine on my end. Can you try testing this in a fresh project to see if you get the same error? It could be related to your current project setup and this would be a good way to identify if that is the case.

I have tried to recreate my project several times following the same steps, straight from the Unreal How To’s (as near as possible since the documentation almost never talks about XCode integration). Each time I have run into different bugs.

The errors I get are from a basic project (either with example content or not) and I do nothing more than add a code file that inherits nothing. In other words I’m not even really interacting with Unreal yet and I still can’t get a stable project that builds and runs consistently. I can’t even get a consistent set of errors to ask about.

I am not a complete noob. I have worked in many development environments, languages and simulation/game/rendering engines professionally for 10 years. I am always excited to learn something new. I was really looking forward to adding Unreal to my toolbox. I am not lazy and just expect things to work without some tweaking. I have spent three weeks creating new projects, reading documentation and trying permutations of different settings. I have never had such a hard time getting a project started.

My impressions are:

  1. Documentation for Mac is extremely lacking.
  2. Integration with XCode is half-hearted.
  3. The solution that I keep seeing everywhere is “Make a new project” which is not an acceptable solution.
  4. There must be hidden settings not available through Edit => Project Preferences or Unreal Editor => Preferences because I have brute forced my way through every single entry and can’t find anything that relates to the error messages I get.

In the meantime I have bills to pay and have to get actual work done. When someone can explain how to actually make a stable project on Mac maybe I’ll revisit it.

I’m sorry to hear that you’ve had so many issues. For this issue however, there may be a fix in the form of changing your build configuration/scheme. There was a similar post here a while back:

If this isn’t able to help you, could you post the full logs from your attempt to launch? A text file would be best. It would be best to see anything else that is going on other than that one error message.

Edit: The reason the first suggestion in most cases is to make a new project is to help identify the problem rather than fix it. If we know that a new project doesn’t exhibit the issues, we can focus on the elements of the project itself instead of the more broad, lower level things or with another program’s compatibility with the engine.


I had the same problem.
Try to select “Cook Content for Mac” under file and then try again.
Also instead of launch you can try to select under file “Package Project” and select (of course) mac.
It worked for me.
Hope it helps.

Hi ,

I have the same issue you had when I try to launch my app on Mac OSX. I have tried a lot of different project settings configurations however no one work. Always appear the same pop up “GlobalShaderCache… is missing”. It only happens in others macs. Both my macbook pro and my iMac run the app without trouble. Maybe because I have UE4 installed in both of them, I don´t really know.

As you said of yourself I am not a lazy person neither. I have been searching for the solution or any other useful tip during the last week and I am really sick of this. My handicap is that I am not a game developer or programmer, I am an architect.

I wonder if you could fix that issue and if you could share it.

I really hope to have notices from you.


Hi ,

Thanks you very much for your response. Finally I got to fix that problem. What I did was download Xcode for Mac from iTunes. Once installed appears new Targeted RHI and Open GL options in Project Settings menu. By setting up Metal SM4 app worked in the others macbook didn´t before.

I hope it´ll be usefull for other users in the future.