I cannot get my blueprint actor to show up in my world outliner

I’ve been following this tutorial(link below) and have been trying for hours upon hours now. I’m using version 4.9.

Also warning code when I try to compile my rungamemode blueprint under Addfloortile. It says " ‘return value’ is already a BP floor tile, You don’t need cast to BP_FloorTile."

Hello Daryn36,

Have you dragged the blueprint into your level? That would be the first step to getting it to show in the world outliner. As for the warning that you receive, you could skip using the Cast To BP_FloorTile node as it says since the return value is already of that class. It was necessary in previous version of the engine, such as the one this video was made in.

We haven’t heard from you in a while, Daryn36. Are you still experiencing these issues? If so, please let me know the outcome of trying the methods I mentioned in my previous post. In the meantime, I’ll be marking this issue as fixed for tracking purposes.

Hey there.
Yeah, I’m on v4.10.2 and I’m getting stuck at essentially this moment. To me, it doesn’t appear that the tutorial has the bp floor tile dragged into the scene. Rather it is generated from the function add floor tile.
I have carefully followed each step up to this exact point @ 05:38 into video 2 - spawning the course.
And the floor tile does not appear in scene when running simulation.

Hello shubes,

Could you provide some screenshots of the relevant blueprints and their event graphs so that I can see if there are any problems? Is the floor tile present in the Viewport inside of the Blueprint Editor?

Hi Matthew,

Yes, the floor tile is indeed visible in the BP_FloorTile blueprint editor viewport.
Meanwhile, am assembling screens…
Thanks!

Ok, so I discovered the solution to my problem and it’s a point that doesn’t seem to be explicitly addressed in the video series. So, it would seem I can’t manage to post screen grab image, can’t get beyond resize preview of image with Galaxy Note 4 (don’t have inet access at moment). Jpg is small size but wide. Anyway, screenshot would show relevant settings plus the missing step that seems to be absent from the video. You need to make sure that your GameMode is set to the correct one: select World Settings from the dropdown menu under Settings and change GameMode Override from none to"RunGameMode" or whateveryoucalledit.

Here’s the screenshot FYI…

Thank you for that information shubes. I took a quick look at the tutorial to see if I could find an explanation for this and it seems that there is one. In the tutorial, instead of creating a new gamemode blueprint, he uses the existing ThirdPersonGamemode but just renames it. In this case, the gamemode would already be set and he wouldn’t have to change it. I’m glad you were able to find the issue however.

Have a nice day!

I cannot put into words how much of a relief this is. I was getting crazy trying to make this work!! Thank you so much!!