I cannot attach a weapon to a hand socket in a first person controller

I’ve tried putting a weapon(skeletal mesh) onto a socket I have in the hand of the skeleton, but it doesn’t work on the first person controller. I’ve followed some tutorials and they all work great for third person controllers, but they all break when it goes to first person. [It has been asked before here but I don’t understand the question at all.][1]

I attach a socket to a finger bone like normal, and attach a statue to it. It looks fine in the preview.

It gets attached at the feet of the character when I play it.

Here’s my level blueprint, I’ve seen this exact script in many different tutorials.

I am completely stuck, and I would love any ideas on how to fix this.

Ive got the same problem =(. Looks like your issue is that your trying to attach to the third person mesh in ur BP. The mesh for first person is “Mesh 1P” that should plug into “In Parent”

It seems that you’ve mismatched your meshes. Judging by the look of the picture, the statue is being attached to the root, which usualy happens when you specify “wrong” socket (in this case the non-existing one). So I would recommend checking what mesh exactly you’re getting out of your character.

Worked it out =)

I was following this tutorial:

There are a few things missed out and these are:

Variable Weapon needs to be Static Mesh Component not static mesh

Most importantly the component ‘Weapon’ isnt mentioned which is what fixes the issue:

I have mine set as so:

And this is what my function looks like

Havent touched collision or set owner only see yet

Thank you so much! I was going at this all wrong, but I got it now. Much appreciated!