I can no longer build on Android

Hello. I started having a recent issue with UE4. I can no longer build for Android by using Project Launcher…
I have my sdk updated, I run VS 2017 and I have the binary version of the engine. This used to work until 2 days ago when it started to give me these errors in the log: ProjectLauncher.log

What I tried so far: Deleting intermediate and saved folders, verify engine files, downloading and installing the engine again, generating VS files again, FILE->Refresh Visual Studio files.

I tried to build and launch it from Project Launcher but on a different platform like Windows and builds just fine.The issue also appears when I try to package for Android. I hope somebody can help me. Thank you in advance!

EDIT: A slightly different log: [ProjectLauncher.log]2

From the log, it looks like you are including a Windows header.

In “SCUE4.h” on line 30, “WindowsPlatformProcess.h” is being included. That is hitting a #error because a define is missing. Don’t include that file when you’re building for android.

Before the error is a warning that the same define is missing but it shouldn’t be a problem. If you want to get rid of it, just define “PLATFORM_WINDOWS” as zero yourself explicitly – before the include statements.

Thank you!

I meet the samething ,I delete the plugin ,it works