Download

I broke unreal 4.25 and 4.26 Help! ;)

I hope i dont have to reinstall windows.
So i was trying to get android working for ue 4.26 but things dont look like the tutorial anymore and first i got it half working, until the error where sdk is not correct. Then i fiddled around with the android studio changed the sdk to another location to try to get the sdk location. Then i gave in that location in ue4.25 android sdk window. At that moment i broke unreal. Whenever i press launch unreal freezes and stops. This also happens in unreal 4.25 now. But not in previous versions. I tried disabling the sdk but it didnt mather. I uninstalled ue 4.26 and its still the same. Whenever i press launch unreal stops working. This happens in Pc version to, and that is what is bothering me.

Can anyone help me with next steps? Thanks a lot!

update i reinstalled windows unreal 4.26 works fine again. Those who are now installing android upgrade, how do you do it step by step in ue 4.26 i assume its the exact same as 4.25. But something went wrong with me.

part 3: i fully reinstalled windows 10 clean, yet android studio still remembered the last known position of the sdk installation. Ps also the installation does not look at all like the unreal tutorial for me! I assume i am going to break unreal AGAIN.

update i installed a later version of android studio 4.01 then it looks like the tutorial and i actually get to the phone play button, but then i get the same error (after following the rest of the documentation)

ERROR: Couldn’t find 32-bit or 64-bit versions of the Android toolchain with NDKROOT: c:/Users/xxxxxx/AppData/Local/Android/Sdk

I assume its because he doesnt know the folder of the ndk or sdk, i have been going in cirkles for 2 days now. This is rediculous. Am i the only one where the documentation doesnt work.

More updates on those interested: i got it to work finally. I downloaded another version of the ndk i used the jdk of android studio and the sdk of android studio version 4.0.1. In my first project it still crashed at the logo launch screen on the phone. But in another project it launched. I also tested sm 5.0 for vulkan and that doesnt seem to work so nice with the packages i tested thusfar.

Anyone else been testing out sm 5.0 for mobile?