I am unable to install the Launcher

Hey guys,

I’ve launched the installer as admin and it installs, after 1 minute at DirectX the installer window vanishes and its gone.
Epic Games Launcher appears on Desktop. but if i try to open it then i get following error message:

41265-unbenannt.png

i also did the “msiexec /i C:\UnrealEngineInstaller.msi /L*V C:\UnrealEngineInstallerLog.txt” command but i cant send the logfile here, cuz its to big.

pls help
TYA
Evo

Hi evolex 1802,

Try the suggestions in this post.

If that doesn’t fix the error, make sure to try all of the steps in this section of the troubleshooting guide.

Then, if the issue persist we are going to need some more info. Follow the steps in this section to generate your Debug Logs and then post them here along with your Dxdiag (system specs).

hey, i tried the dll cleaner and nothing changed, still the same error. here are the last few colums of my logfile. === Logging stopped: 04.05.2015 16:39:41 === MSI (c) (5C:34) [16:39:41:603]: Note: 1: 1707 MSI (c) (5C:34) [16:39:41:603]: Product: Epic Games Launcher – Installation completed successfully.

MSI (c) (5C:34) [16:39:41:605]: Windows Installer installed the product. Product Name: Epic Games Launcher. Product Version: 1.1.27.0. Product Language: 1033. Manufacturer: Epic Games, Inc… Installation success or error status: 0.

MSI (c) (5C:34) [16:39:41:608]: Grabbed execution mutex. MSI (c) (5C:34) [16:39:41:608]: Cleaning up uninstalled install packages, if any exist MSI (c) (5C:34) [16:39:41:609]: MainEngineThread is returning 0 === Verbose logging stopped: 04.05.2015 16:39:41 ===

if i read this right, the installer get installed succesfull ill attach u my dxdiag file

link text

Thanks for the info. Could you also post the entire Debug Log? If you have to, feel free to zip it and post a download link here for either Dropbox or Google Drive.

hey TJ

heres the googledrive link: Google Drive: Sign-in

There might be some slight confusion about the logs that we’ll need. You are correct, if you are seeing that error message then that means the install completed but the launcher is failing to start due to an unknown dependency issue. In this case, the installer logs won’t help. I’m not sure the launcher logs will be very helpful in this case since we usually have to track down these types of issues using a tool called DependencyWalker. You can read more about it here: Unreal Engine won't launch Error code (0xc000007b) - Installation & Setup - Unreal Engine Forums

hey ive done this with Dependency Walker, theres the logfilelink text

The logs have some interesting entries. Unsure if this is the root cause of the problem but these lines spread across the log file jumped out at me:

[ E ] c:\windows\system32\D3DX11_43.DLL

Loaded "D3DX11_43.DLL" at address 0x0000000064330000.  Successfully hooked module.
Unloaded "D3DX11_43.DLL" at address 0x0000000064330000.
Loaded "D3DX11_43.DLL" at address 0x0000000064280000.  Successfully hooked module.
Unloaded "D3DX11_43.DLL" at address 0x0000000064280000.

The [ E ] signifies that the file could not be loaded. This leads me to believe, that file is corrupt in some way. I would try the following:

  1. Backup this file c:\windows\system32\D3DX11_43.DLL by renaming it to D3DX11_43.DLL_BACKUP

  2. Run the DirectX setup from your Epic Games install folder(The default location is here C:\Program Files\Epic Games\DirectXRedist\DXSETUP.EXE ) Or you can download it from the Microsoft website.

  3. Ensure a new version of this file was put here: c:\windows\system32\D3DX11_43.DLL

  4. Try running the launcher again.

Problem solved, tya guys