Download

I am probably stupid but i can't understand how remap works

All in the title, i am trying to replace some structures by others by using the remap but it doesn’t work
For instance i made a copy of the compost bin (structure) where you can store meat and cooked meat to spoil them faster, i tried to use the remap to replace the existing compost bins but it doesn’t work, also new compost bins are vanilla compost bin.

Did i misunderstand something?

When you say it doesnt work is it crashing or something else can you explain alittle more. I dont know everything but i have copies structures before successfully. Made a Bio Bin that makes gas from **** really poo is a bad word.

Can you explain the step you did when you replace your compost bin? then from that we can help you by poitting out your missing step

Here a link where i explains some on modifing the inventory. https://forums.unrealengine.com/showthread.php?82945-Modifying-structure-inventory

have you duped or maded the compost bin as a child?

I only made a copy of the compostbin and chanbed its inventory component, couldn’t acess the inventory component when it was as a child
Then i remaped from compost bin to compostbincopy (in items and npc, not sure for npc, i hoped that would remap for already placed bins)

I had tried to copy the primal_structure_item copost bin and change remap it (it worked, but then i couldn’t place anything with it, even when i changed the “structure to build” on the primal item and the cosumes item on the compost bin)

I guess i don’t know how to remap correctly, the inventory change works if i made it a standalone item

Had a similiar issue earlier I restarted the dev kit and it let me place the structure. But it wouldnt place before that. Didnt edit a thing. Maybe your issue ever since 206.2 Had weird issues. Another problem I had which was why I was remaking mine in single player not servers it would crash on placing berries in my bin. Odd right. Just copied it and relinked it then wouldnt place restarted kit and it worked.