I am getting this error when packaging my Android app, can i get help to source the error?

Hey! Whenever I try to package my file it seems to fail all the time, I will link the packaging log from where the error starts, help would be greatly appreciated!

UATHelper: Packaging (Android (All)):      [aapt] D:\GreatValue\GreatValue\Intermediate\Android\APK\bin\AndroidManifest.xml:1: Tag  attribute package has invalid character '['.
UATHelper: Packaging (Android (All)): BUILD FAILED
UATHelper: Packaging (Android (All)): C:\NVPACK\android-sdk-windows\tools\ant\build.xml:649: The following error occurred while executing this line:
UATHelper: Packaging (Android (All)): C:\NVPACK\android-sdk-windows\tools\ant\build.xml:694: null returned: 1
UATHelper: Packaging (Android (All)): Total time: 30 seconds
UATHelper: Packaging (Android (All)): Program.Main: ERROR: AutomationTool terminated with exception: System.IO.FileNotFoundException: Finner ikke filen D:\GreatValue\GreatValue\Intermediate/Android/APK/bin/GreatValue-release.apk.
UATHelper: Packaging (Android (All)): Filnavn: D:\GreatValue\GreatValue\Intermediate/Android/APK/bin/GreatValue-release.apk
UATHelper: Packaging (Android (All)):    ved System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
UATHelper: Packaging (Android (All)):    ved System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
UATHelper: Packaging (Android (All)):    ved UnrealBuildTool.UEDeployAndroid.MakeApk(AndroidToolChain ToolChain, String ProjectName, String ProjectDirectory, String OutputPath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bMakeSeparateApks, Boolean bIncrementalPackage, Boolean bDisallowPackagingDataInApk)
UATHelper: Packaging (Android (All)):    ved UnrealBuildTool.UEDeployAndroid.PrepForUATPackageOrDeploy(FileReference ProjectFile, String ProjectName, String ProjectDirectory, String ExecutablePath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bIsDataDeploy)
UATHelper: Packaging (Android (All)):    ved AndroidPlatform.Package(ProjectParams Params, DeploymentContext SC, Int32 WorkingCL)
UATHelper: Packaging (Android (All)):    ved Project.Package(ProjectParams Params, Int32 WorkingCL)
UATHelper: Packaging (Android (All)):    ved BuildCookRun.DoBuildCookRun(ProjectParams Params)
UATHelper: Packaging (Android (All)):    ved BuildCookRun.ExecuteBuild()
UATHelper: Packaging (Android (All)):    ved AutomationTool.BuildCommand.Execute()
UATHelper: Packaging (Android (All)):    ved AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
UATHelper: Packaging (Android (All)):    ved AutomationTool.Automation.Process(String[] Arguments)
UATHelper: Packaging (Android (All)):    ved AutomationTool.Program.MainProc(Object Param)
UATHelper: Packaging (Android (All)):    ved AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
UATHelper: Packaging (Android (All)):    ved AutomationTool.Program.Main()
UATHelper: Packaging (Android (All)): Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)
UATHelper: Packaging (Android (All)): BUILD FAILED
PackagingResults:Error: Error Unknown Error

Heiaas,

Have you tried deleting your Intermediate and Saved folders from your project folder?

No i have not tried that, i will try it as soon as i can. Thank you.

You’re welcome. Let me know once you’ve tested that out. :slight_smile:

We haven’t heard from you in a while, Heiaas. Are you still experiencing this issue? If so, have you tried what Samantha suggested previously? What were the results? In the meantime, I’ll be marking this issue as resolved for tracking purposes.