Download

Huge Sockets using blender and makehuman

Here is what is happening.
2d1dc8fb718d4f334cc85f933ec4f7d3642bc1cf.jpeg

It’s probably some issue in blender, but I don’t know what it is. Here are my export settings.
6d9ae7433ceb83e29eb6a693503b43f14cae3fd5.png

If I place a preview on the socket it’s huge as well.

Blender file:
https://www.dropbox.com/s/ltohxzp6m2zcizz/Testy.rar?dl=0

-are you sure that your character isnt just too small?
-what happens when you select the mesh in blender - object - apply- scale/location/rotation? :slight_smile:

I’ve tried applying rotation, location, and scale. Also, if I scale up the character he will be huge inside UE4. I’ll attach my file for anyone who wants to have a look.
https://www.dropbox.com/s/ltohxzp6m2zcizz/Testy.rar?dl=0

Hmm some things.
I set scale in blender to 0.001 metric, you use 0.1.
Press N in Blender and look at mesh dimensions < 10mm height.
Then you have no restpose at frame zero a/t-pose(important).
The rigify skeleton is ok for animation, but not so well for gaming.
Inside MH use topology and export a lowpoly too, at minimum better for testing.
Look here UE4 Tools Addon - Lluis Garcia
[ADDON BLENDER] UE Tools - Community Content, Tools and Tutorials - Unreal Engine Forums
Look in MH for the different skeletons (try gaming).
But there is a big but, because you could not easy use the standard animations for Hero TPP.
In the ue tools, there is a mannequin template.
When you use that as a base for sizing and restposing, you can easy use the ue4 skeleton.
No retargeting stuff needed, all basic animations working.

The large socket scaling is being caused by the Apply Unit property in the fbx export settings. You’ll tend to have problems like that any time you let the exporter rescale the model for you. The fix is to make sure your object is scaled properly before export (ie 1 blender unit = 1 unreal unit). Then in the export properties set Scale to 1.00 and uncheck the Apply Unit box.

The downside is that the model inside blender tends to be larger than what blender likes, so you might want to scale up right at the end or increase the clipping view distance.

Hope this helps.