Download

Huge problems with cloth simulation for character clothing

I am using a low poly shirt as a cloth section, and applying that to a higher poly shirt from marvelous designer.
When the character folds his arms you can see the nasty “jump” of figure one. That jump does not occur at the exact spot where the MaxDistance mask turns to 0 (purple). Instead the mask is still dark grey (almost black) for a good piece of the arm (see fig 4)

The second photo shows the low poly mesh in white.

When I click ctrl-alt-c to reset the cloth simulation the problem is resolved (fig 3) but reoccurs predictably every time the animation reaches a certain point.

  • there is no physics asset linked to this skeletal mesh
  • no permutation of parameters fixes the issue (I was on this for 2 straight days, all day, tried self collision, and randomly tweaking all of the completely undocumented parameters like bend, shear, drag, etc)
  • I have tried making the low and high poly meshes more similar (i.e. not using marvelous designer meshes, but a zremeshed clean quad mesh as high poly mesh, and an unsubdivided version of that as low poly mesh with exactly 1/4th of the faces). This resulted in different patterns of errors but still errors of similar magnitude.
  • I tried adding more loops near the elbow, and smoothing very well, but it did not change much.
  • could the problem be caused by the fact that the high poly mesh is deformed with a “nearest vertex” (not interpolated) algorithm?
  • isn’t there some parameter that tells the simulation what the smallest ‘maxdistance’ to simulate should be? At the moment it’s not a 0 threshold, but higher than that, sufficiently higher that there’s always a jump between the deforming part and the non-deforming part visible as bad normals or an actual bump in geometry