Huge Animation Problem (3DS Max to UE4)

I have rigged and skinned a basic character in 3DS Max and exported it to UE4, but, when I import into UE4 I get the same error. I have watched quite a few tutorials and I am sure I am rigging and skinning my character correctly, but when in UE4 I receive the same error over and over. When I try to control my character in UE4, it moves but does not animate. I have recorded footage of the process I have gone through. Please take a look at the following link. Thank you all in advance as this is really driving me crazy now.


Hi SpencerHolmes,

The issue you are having is that your skeleton is not compatible with the skeleton of the standard character. That’s what the error message you are receiving (failed to merge) means. Because you then force regenerated the skeleton the data is now invalid and none of the animations can use it so your character does not animate.

There are a couple of options to resolve this. First you could use a compatible skeleton in your DCC tool (either export the ref pose from UE4 or get the base character FBX from this link:

Reskinning your character might be a lot of work however depending on the complexity of your rig so we also have in-editor retargetting for differing skeletons. Here’s the documentation for this feature: This feature will allow you to retarget your skeleton onto the skeleton used for the standard character and should allow its animations to work with your character.

Hopefully this helps!


Firstly, thank you for your response. I used the biped system in 3DS Max, do you think I should be using the bone tool instead? If so, I have not used bones before, therefore I don’t have much knowledge of setting up roots etc. Is there a tutorial on bones creation for 3DS MAX that you know of?

Thank you again!

The biped system is likely fine to use if you’re making your animations from scratch. If you’re trying to make anything that is non-humanoid then or just more complicated then the bone tool is the way to go.

The reason that the biped is causing this issue is just because it uses a different hierarchy than the default UE4 character, not because there’s something wrong with it.

I don’t know of any 3DS Max tutorials dealing with the default character skeleton unfortunately.

To get the same hierarchy in 3DS Max you can either recreate it in the bone tool (making sure that you keep the hierarchy and names the same) or export the default character from the editor and use that skeleton to skin your character to in Max. To do that just right click on the skeletal mesh asset in the content browser and click “Asset Actions” → “Export…” and save it off to an FBX. Next import that into MAX and remove the default character geometry. Skin your new character to that skeleton and it should work when you import it.

Thank you. I am going to use the UDK skeleton. You have been a great help. Thank you Excelcior!

Mhh, no T-Pose set on frame 0?
When you export for example a model with animation from frame 1-xxx,
and then the next with another animation from 1-xxx the position of bones in first used frame is different.
In Blender it is a must, to set a T-Pose at frame 0 before export, and if you use the same T-Pose for every model, at frame 0, retargeting works.
If not, i get same errormessage like you.
Forgive me worst case english ^^

It’s interesting that you posted Luftbach. I am having more problems now. I managed to retarget fine but I get the following result, which is in the video in the link. I am sure if I had a t-shape I wouldn’t get this.

Excelsior, do you have any input on this please?