HUD not Showing New Widget


  1. I create a HUD overlay, it works.
  2. I press play It shows.
  3. I create a new blueprint widget,
  4. I add it to the HUD.
  5. I press play
  6. Everything works, except it does not show the new widget.

Its been a problem for days, I am stating to think I have frozen something from letting new widgets enter?
I have tried to play wth Zdepth.
I have tried to recreate it.

Its a simple mechanic, when the character overlap an “Press F” is suppose to show up on the screen. No trouble. But now I am just stuck, any help is much appreciated.

Thank you for your time,

Maybe the visibility is changed to “hidden” or “collapsed”?
You would see it in editor but not at runtime.
It’s hard to guess the error if you have no access to the code xD

Okay I found the answer myself.

First I had to set it to Horizontal Box instead of Canvas Box in the FWidget blueprint. That made it display.

After I added a visibility switch as a function in the Visibility Behaviour tree.

Simple enough after that.