HUD gamepad

The hud worked well on pc, but since I selected use mouse for touch in the input section, the gamepad got covered by the hud. After I set the hud to invisible, the gamepad still can not be manipulated.
Here is a sceenshot:


I think I can call some sort of event which can trigger the gamepad to uncover the hud, but I cant find it.

Hello davidg0,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints that may be involved with this issue?

This issue only happens after I connected the hud. The hud is from a project in the market place called the survival game template. After you open the project, you have to set use mouse for control, and then the two mobile gamepads will appear, you can find that it cannot be manipulated.
And I’m 100 percent sure the problem is about the sgt_master_content blueprint under the blueprint folder.

When you say “hud” do you mean UMG? I was able to reproduce this using UMG but not HUD. If you are using UMG, you will need to set your widgets to “Self Hit Test invisible” I hope that this information helps.

Make it a great day

Could you please tell me more details on how to set those to work? Thanks a lot for help! And it is UMG :slight_smile:

Ok, solved it. :slight_smile: