Download

HTML5 works in the editor but not when I package it:(

I have a small game. The example level and my main level. I build both levels with production quality lighting and under the File menu, package project, packaging settings I go to maps & Modes and change the Game Default Map to start my game on the ExampleMap level. So when I play my game it will start at the first level it needs to.
Next, At the top right Launch icon I click that and I try and launch an HTML5 game in firefox. It takes a few minutes and then a firefox window appears and the game compiles and eventually plays just fine.
When I go to File, Package project, HTML5 it asks me where I want to store the project and I tell it to put it in it’s own folder in my documents. It takes awhile and when It is done it tells me packaging complete.
I open the packaged project folder and it gives me these files:

Folder=

HTML5

inside Folder=

Dungeon.data
Dungeon.data.js
Dungeon-HTML5-Shipping
HTML5LaunchHelper
Readme
RunMacHTML5LaunchHelper.command
UE4Game-HTML5-Shipping.js
UE4Game-HTML5-Shipping.js.mem
UE4Game-HTML5-Shipping.js.symbols
Utility.js

So it looks like everything worked:) My game runs beautifully. The sound, music, lighting, and shadows work in the game while I launch it while inside Unreal Engine 4.9
I try to open game-HTML5-Shipping (Firefox HTML Document)
and Everything loads on the web page but my game.
I see four blue buttons: Pause, Resume, Clear Stored Game, FullScreen
Then the game seems to be compiled below:

Starting downloads
Starting download Utility.js.gz
Starting download Dungeon.data.js.gz
Starting download UE4Game-HTML5-Shipping.js.gz
Utility.js.gz downloaded
Dungeon.data.js.gz downloaded
downloading symbols file
downloading symbols file
symbols file downloaded, demangling…
callstack ready …
symbols file downloaded, demangling…
callstack ready …
UE4Game-HTML5-Shipping.js.gz downloaded
downloading symbols file
symbols file downloaded, demangling…
callstack ready …

But all I see is a pink little box where the game should be displayed up top:( What am I doing wrong?
This is my Game in the HTML5 folder it creates:
Dungeon_HTML5_Project2.jpg
This is everything inside that folder:
Dungeon_HTML5_Project.jpg

same here…

Hey Everyone,

Please upload a question to AnswerHub so that we can assist you further. Please make sure that your post is as detailed as possible and include any logs you may have acquired. Let us know the site you’ve been uploading to as well.

Thanks!

sometimes it’s create.

Hi,

Did you use HTML5LaunchHelper.exe? Use it and go localhost:8000//Dungeon-HTML5-Shipping.html

thats solved my issue , thanks :smiley: