HTML5 panner.SetVelocity

Hey guys,

Ran into a weird error on Chrome v 59.0.3071.115 Firefox,Safari, and Edge still work fine.

The only information on it that I have found is about the panner.setVelocity being obsolete from Mozilla: PannerNode.setVelocity() - Web APIs | MDN

The error only seems to come up around 90% of the play throughs (Game is very short) and not at the same spot each time.
Really leaning towards maybe an emscripten error?

This link seems to point towards a change in audio doppler effects. How could that be stopped in the engine?

Tried getting rid of all of the panners in my materials and all kinds of different build settings. Tried 4.14.3 + 4.15.3

Image attached is the error in questions.

Any advice or ideas or direction are welcome!

Try updating to latest UE 4.16, that should fix the issue.

The problem here is that Google decided to remove already released functionality from Web Audio spec, which broke all web sites out there that use Web Audio doppler effects on Google Chrome. Other browsers did the removal better by making the .setVelocity() function do nothing (but still exist, so that already released web pages will not break). Emscripten removed the use of .setVelocity() about a year ago, which I think went in to UE4 some time between 4.15 and 4.16 releases.

If for some reason you are not able to update to newer UE4 but would like to work around this issue in the existing version, then you can also try just editing all the build output .js files, and search for “xxx.setVelocity(…)” calls and wrap those in /* xxx.setVelocity(…) */ comments. If I recall correctly, there should be exactly two such places where that appears.

Alright, I will give that a shot first since this project recently gave me a lot of trouble getting it into 4.15. Will update

Commenting out the panner.setVelocity in the Game-HTML5.js caused a lot of other issues. Ended up porting the project to 4.16 and got it working as suggested in your first post. Now everything besides the GUI elements are rendering black, but that is another issue. Thanks for all the help!