Download

HTML5 not working on 4.7.2 Black Screen

Hey,

My games published to html5 perfectly well on 4.7.1 and 4.7.0, (see for yourself: dazpetty.itch.io), despite what epic said about this technology being unreliable, it worked perfectly on every computer I tried.

Now when I even publish one of the basic templates to HTML5 I just get sound and a blank black screen where the game should be, and I don’t think it’s possible to downgrade from 4.7.2 to 4.7.1.

They did describe this problem occurring with 2D games, and I’m not talking about a 2D game, the games I published pre-4.7.2, still work perfectly in my browser.

I mean come on Epic, to take away proper Android support with no OBB file downloader in 4.7.0, then to give us HTML5 and just take it away, it just makes me really upset, if I can’t test my game in a browser and make sure the materials work correctly, then all my work comes to a grinding halt.

Hey Neurocase,

In order to better assist you better, please submit a question to our AnswerHub. Please make sure that you include as many details as possible regarding the issue that you’re seeing, so we are able to reproduce this issue and submit any bugs found to our Developers.

Thank you!

I had the same problem with HTML5 in 4.7.2 and 4.7.3 for me the problem was anti aliasing if i used FXAA or no anti ailising i got jet black screen but if i used temporal AA i got things back.

AA settings can be found in project settings in the render tab it will have three options none FXAA TempAA.

i have no idea why this made my project go black screen but with TempAA it came back for me.

Another problem with black screen in HTML5 came from some of my post process settings but i could no lock down which one due to the problem being intermittent.

hope this helps

Is there any other solution?
mm to cm

miles to km

inches to cm