HTML5 - how to make it work?

Ok, guys, I have created an empty project without any content and try to build in HTML. Build procces have been completed fine without any errors. I tried to do it from UnrealEditor and by Frontend tool. But my html file is not working in any browsers (32 or 64 bit). Finally, what I have to do to make it work? Please, give me some help.

Hey Alex,

Did you locate the HTML5LaunchHelper.exe file that’s included within your packaged project folder? If not, please launch that first, then open a browser for testing and browse to the location of: http://(machinename):8000 and it should populate for you.

Let me know what steps you’ve taken, thanks!

Hi Samantha, thank you for your participation.
My packaged project folder doesn`t contain HTML5LaunchHelper.exe. But I found it in UE4 DotNET folder and launch them. What shoud be happen? Then I opened browser and typed http://(machinename):8000 but it not working. I have tried put HTML5LaunchHelper.exe file in my packaged folder, no changes.

Please, tell me step by step what I have to do?

Here is my packaged folder after package is complete and browser:

It seems you’re not on a new version of the engine. Here are the instructions on launching your HTML5 project in an older version of the engine:

  • Package the project for HTML5
  • Navigate to the folder where the packaged project was placed
  • Locate the HTML5LaunchHelper.exe file
  • Double Click the helper file
  • A DOS prompt/command window will open
  • Open browser being used for testing
  • Browse to location listed next to Starting Server at: http://(machinename):8000

Please make sure you’re using Google Chromium or FireFox Nightly.

I have tried in UE 4.10 and Nightly.I created empty project without any content. I did steps that you tell me and I have tried to launch direct from editor and in a both case what I got:

Which version of 4.10 are you on? Is it from Github or the Epic Games Launcher? If it’s from GitHub, you may want to rebuild the engine and for HTML5. If it’s from the Epic Games Launcher, you may want to try and ‘verify’ 4.10 and see if that helps any.

Once you’ve done this, repackage your project and try again. Let me know how it goes.

I use version 4.10 from Launcher. I have tried verify and packaged my project again - no changes, there is the same errors.It doesnt work anyway. I dont now what am I doing wrong…

It looks like your WebGL: framebufferTexture2D is at a higher level than 0. The error states that it must be level 0. Please make sure that your mipmap level of the texture images are always set to 0.

Where can I find this parameter? I couldnt find it.

Alex,

I spoke with our HTML5 developer and he shed some additional light on the issue that you’ve been experiencing.

The framebuffer issue looks like it’s just missing the texture. Since it looks like you’re trying to render an empty scene, there may be an object that got in the scene (that’s likely missing a texture) and that is what the “error” output seems to be stating.

Please keep in mind that without seeing your project, it’s hard to determine if this is the exact issue, but that’s how it seems at this time.

Also, the actual error (the pink box) seems to be crashing on the slate handler - - OnControllerAnalog(). This likely means that there is a HUD object that’s trying to access something that isn’t currently set properly. We believe that your mouse handler got triggered and caused a crash.

Please reply back with any additional information you can provide, or perhaps a link to your project?

Thanks!

Samantha,
My project is default and has no any special things, but I attached it anyway.

About your words “mouse handler got triggered” I dont fully undarstand what you means. I have connected graphics tablet, maybe it causes that problem.

Alex,

I was able to successfully launch your project within Google Chrome and FireFix (including Nightly). I do not have any digital tablets attached to my computer so I’m wondering if that’s the issue that you’re running into. Have you tried unattaching your drawing tablet and seeing whether or not that was the main culprit to launching a HTML5 project on your computer?

I have tried unattaching my tablet and it still doesn’t work (the same error). Please try to launch my build, maybe I do somthing wrong with packaging process? I make a build direct from UE editor.

My HTML5 build: Google Drive: Sign-in

Your HTML5 project does not run for me. The temporary server is not working correctly either. Could you tell me how you set up your HTML5 project before packaging it?

I have taken the project that you gave me earlier and I have packaged it for HTML5 by going to File > Packaging Project > HTML5. I did not change any of the settings. Could you please tell me if you changed any of the settings within HTML5, did you change how it packages?

This is my packaging set up.

Please go to the folder and run the HTML5LaunchHelper.exe. Inside of the server, it tells you a localhost to go to. Please open up FireFox and type in the server address in the address bar. If it doesn’t load up then, please try Google Chromium.

I already have treid all of it many times. Please give me link to your HTML5 build of my project (which you successfully launched on your system), I will try it on my system.

Double-click on the HTML5LaunchHelper.exe. From there, open up Google Chrome or FireFox and type: http://localhost:8000/ and it will load up your project onto the browser. This will be a local server.

Samantha, you didn’t understand me. I have done all as you told me and got error like I posted erlier. Send me your build (package) which you successfully launched on your system. I will try to launche it.

Here is a link to the project I have created and packaged: HTML5 Project and Package