HTML5 doesn't appear as a launch target

After following the instructions at https://docs.unrealengine.com/latest/INT/Platforms/HTML5/GettingStarted/index.html, I still don’t see HTML5 as a launch target in the editor (and yes, I’ve restarted).

Relevant info:

  • Windows 8.1 x64
  • Engine version 4.7.5
  • I’ve installed Python 2.7 to C:\Python27, have this directory in my PATH, and can access the interpreter by typing python on the command line.
  • I’ve installed the Emscripten SDK via the recommended installer on the above link and can run binaries from the command line.
  • I’ve installed Firefox Nightly to C:\Program Files\Nightly\firefox.exe
  • Contents of my PATH environment variable: http://pastebin.com/zRDZnQdv
  • Contents of my Config\HTML5\HTML5Engine.ini file: http://pastebin.com/CkV6sKYn

Any ideas?

Hey Rohoon,

Have you looked in the ‘Device Manager’ within the Editor? You can get to this area by clicking on the drop-down option beside ‘Launch’. You may need to make sure that HTML5 is connected and claimed by you. You can do that by selecting the HTML5 device and right-clicking and selecting ‘claim’. You may also want to look under ‘Project - Supported Platforms’ and ensure that HTML5 or All Platforms is selected for what your project is supported in.

Please let me know if this section is set up correctly or not, thank you! :slight_smile:

Hi Samantha,

I’ve double-checked those things. HTML5 is definitely checked as a supported platform. The Device Manager doesn’t show HTML5 anywhere, including in the ‘Unlisted Devices’ dropdown.

Hey Rohoon,

in the HTML5 ini file, just below Mac, could you please add a Windows=“pathtoemscripten” and remove the other sections which you previously added, which are the emscripten and python settings.

If that doesn’t work, add a system ENV variable “EMSCRIPTEN” which contains the path to emcc.

Hopefully this resolves the issue that you’re experiencing. If it does not, please update this thread so we can further assist you.

Thanks!

I already had the EMSCRIPTEN environment variable in there, so it appears that your first suggestion was the one that did the trick. It only showed up in the “Project Launcher” dialog and not the “Launch” dropdown from the main toolbar, though - is that intentional?

Despite all of this, I now get an emscripten error for both Nightly and Chromium builds. Log file here: http://pastebin.com/HRH5sD7w

I can add this as a new question if you like, though.

Hey Rohoon,

When you’re using Project Launcher that’s more similar to Unreal Frontend. It’s not the same as simply using the drop-down launch on feature. Have you tried updating your version of the editor to 4.7.6 by the way?

Thank you!

Hey Rohoon -

Thanks for trying this out - I was wondering if you could do the following work around

on command prompt ( I see you have everthing on path): try:

 python embuilder.py build struct_info

and then build again?

If that doesn’t work, try downgrading the sdk to 1.25?

Thanks -
Ankit.

Yes, I updated to 4.7.6 prior to submitting the question.

Hey Rohoon,

We have not heard from you in quite some time. For tracking purposes, we must close your thread. However, if you’re still experiencing trouble with HTML5 not appearing within your launcher, please update this post accordingly.

Thank you!

Hi Ankitkk,

Your suggestion worked. Once I had done that, the Firefox options showed up in the “Launch” drop-down and the project built and ran with no issues.

Hi Samantha, sorry about that. Ankitkk’s suggestion (see above thread) solved the problem.