HTML5 build stuck on 'Downloading...'

I am trying to package my project for HTML5 but I ran into a problem that I don’t know how to fix. I followed all the steps from the official documentation and from this question, namely:

  1. I installed Emscripted and ensured the paths in the .empscripten file are correct;
  2. I compiled the source from Github (Win64 Development Editor and HTML5 Shipping);
  3. I followed Ben Donatelli’s instructions (from the question linked above):
    * I launched Engine\Binaries\Win64\UnrealFrontend.exe;
    * in the ‘Game Launcher’ tab I chose ‘Advanced…’;
    * I ticked the ‘Do you wish to build?’ checkbox;
    * in ‘Cook’ I selected ‘By the book’ and selected the only map I had;
    * In ‘Package’ I selected ‘Package & store locally’ and left the fields blank;
    * in ‘Deploy’ I selected ‘Copy to device’ and ticked ‘HTML5’;
    * I pressed ‘Launch’;
  4. I opened the (only) generated HTML file through localhost (I used XAMPP).

The problem I’m running into is the same as 4ndy’s (also from the linked question): the web page just displays an empty canvas with the text ‘Downloading…’ above it.

If it’s any help, here’s the log generated by the Frontend while building:

Hi alexstoinescu
Have you tried loading the page with FireFox Nightly? I ran into a similar issue with Chromium64.

Hello b14de, I tried loading with FireFox Nightly but unfortunately with the same result.


Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes. If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, could you please submit a new report for it.