HTML5 build fail

Hi,

When I try to launch firefox version of my project in the Editor it fails building.

LogPlayLevel: BuildCommand.Execute: ERROR: BUILD FAILED
LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception:
LogPlayLevel: Program.Main: ERROR: Exception in AutomationScripts.Automation: Client exited with error code: 1

Any ideas? The project builds perfectly into Win64. Also if I tried to package the game to HTML5, that process doesn’t fail, but the generated file runs into an “Assertion failed: Cannot call unknown function on_fatal (perhaps LLVM optimizations or closure removed it?)”

I’ve attached the log file.

Hello Cvax,

Are you using the GitHub version of UE4? If so, it’s possible that a step could have been missed, since the engine needs to be built for HTML5. Please review the following link, to insure that you’ve completed all of the requirements for building for HTML5 on FireFox.

https://docs.unrealengine.com/latest/INT/Platforms/HTML5/GettingStarted/index.html

Please let me know if you have any further questions, thank you! :slight_smile:

Hello CVax - It may be the case you already have firefox process open.

Cannot get HTML5 to run - Platform & Builds - Unreal Engine Forums might help you out.

Hi Samantha,

I am having the hardest time trying to follow these instructions. Do I or do I not need the emscripten/fastcomp repositories or can I just get it from the SDK? Building fastcomp is proving to be incredibly challenging as the listed instructions are riddled with bugs on building for Windows.

What I have so far:

  1. I aborted my attempt at building emscripten from source.
  2. Using emscripten as installed per SDK
  3. emscripten development environment verified as per their test scripts
  4. In Unreal’s HTML5Engine.ini
    [HTML5SDKPaths]
    Emscripten=“C:/Program Files/Emscripten/emscripten/1.29.0”
    Python=“C:/Program Files/Emscripten/python/2.7.5.3_64bit/python.exe”
  5. Ran “Setup.bat -include=HTML5”
  6. Ran “GenerateProjectFiles.bat”
  7. Set solution configuration to Development on HTML5 platform
  8. Tried to build, but getting errors. (Right click > View Image to see screenshot bigger)

http://i.imgur.com/bj2y6yr.png

[The VS Output Log][2]
In these logs it is distinctly complaining about this:

`In file included from C:/Program Files (x86)/UnrealEngine/Engine/Intermediate/Build/HTML5/UE4Game/Development/Engine/Module.Engine.2_of_30.cpp:12:

1> C:/Program Files (x86)/UnrealEngine/Engine/Source/Runtime/Engine/Private/BlueprintGeneratedClass.cpp:285:35: error: no member named ‘PreloadAllTempates’ in 'UInheritableComponentHandler’

1> InheritableComponentHandler->PreloadAllTempates();`

This here is the commit in question from yesterday that is causing problems.
https://github.com/EpicGames/UnrealEngine/commit/75134784bc0fd3f7e4e2dc7fed19894c197c8fc1#diff-52bc1fa51c0c10293c29976f722f4eb8

Hi cvax,

You can avoid having to build fastcomp, etc yourself if it’s difficult on Windows. On windows, I find that “emsdk update” “emsdk install [SDK VERSION]” & “emsdk activate [SDK VERSION]” is enough to build HTML5 on windows. I think SDK VERSION would be sdk-1.29.0-64bit for you.

As for the error, I’m not sure what’s happened with that commit (mistake, maybe? CIS has only just picked it up) but best bet for now is to checkout the commit before it (so c9c2789) and run from there until a fix is checked in.

CVax - try installing 64bit firefox nightly and see if it works - 32 bit browsers have only so much memory and that possibly happening in this case

Hi JoJo,

I removed the commits and was able to build the engine for HTML5. When I go to the Editor, I was able to successfully launch HTML5. My game worked perfectly in Firefox.

However I ran into issues with the packaged version. When I switched to Shipping build configuration and trying to package the game to HTML5 it packages without a hitch, but when trying to run the generated .html I run into errors that did not exist when just launching from Editor.

Runtime Error

In the .html’s output box area it says this:

Cannot enlarge memory arrays. Either (1) compile with -s TOTAL_MEMORY=X with X higher than the current value 536870912, (2) compile with ALLOW_MEMORY_GROWTH which adjusts the size at runtime but prevents some optimizations, or (3) set Module.TOTAL_MEMORY before the program runs.

Thanks. 64bit nightly works with the shipped build.

So… 32bit firefox works with the launcher build in \Binaries\HTML5 (confirmed working), but for actual packaged builds I have to use 64bit?

Cvax,

Ankitkk was suggesting that it’s best to use 64bit FireFox because it doesn’t have the same memory issue that 32bit browsers seem to have. Basically, if your game runs out of memory, it’ll crash and this could be the issue you’re seeing currently.

However, I will state that it does say in the Unreal Engine documentation that a 64bit browser is required.

https://docs.unrealengine.com/latest/INT/Platforms/HTML5/GettingStarted/index.html#64-bitbrowserrequirement

If you have any further questions, feel free to respond to this thread and we will assist you further.

Thanks!

I have the same error running firefox (which apparently only has one version which caters for both 32 and 64 bit)

I’m launching from the editor directly 4.10.

Any suggestions anyone?

I also have this error:

LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_1b4c_0///####STATCAT_Advanced#### old //STATGROUP_Threads//FLauncherTask///Thread_a9c4_0///####STATCAT_Advanced####

3d Illusions,

Please create your own AnswerHub thread and provide as much information you can about the issue that you’re running in to. We will be more easily able to assist you there.

Looking forward to hearing back from you, thanks!