Download

How would I got about destroying a destructible with a trigger box?

It was working just fine until 4.13 rolled around.

This is how I was doing it before 4.13, and it was working just fine:

I also tried using a radial force bp:


ps: it is in ‘‘beginplay’’ 'cause I was just testing it.

This is how the bp looked:

Can anybody please help me out?This has been bugging me for the longest.
Thanks.

Try to select a “DamageTypeClass”. Not sure if that’s the fault, but worth trying (:

Had tried that before and just tried it again, no success.
Also trying applying damage directly to the destructible, also no success!

Update:
Well, tried in another 4.14 project(brand new) and the same code I was using worked just fine.
It just doesn’t work in my project…
What can I do about that?

U have to use Apply Radius Damage, it goes fine at least for me. If is a multiplayer game ->Server->all->Apply radius damage . More info Apply Radius Damage | Unreal Engine Documentation

I’ve tried that, no success either.
Funny thing is, in other projects, it works just fine…
Have no idea why that is!
I’ll learn how to use Nvidia’s APEX and try that!

I want to know the solution to this. Have u done well the destructible mesh? I have em even in multiplayer replicating to everyone, is so strange… and u say in other projects u can do it… u have deactivated something related to destructible meshes? Or Dmg cap, or something? When the command of damage to the destructible starts, if u set the destructible in the middle of the air, it doesnt drop with physics awake? Perhaps that destructible keeps Asleep or something…

In my game u can build houses and later make holes in the walls, it does event on beginplay to going well, i cant understand guy, this would be a kind of bug or glitch if its all good done, but i would check it more for some options you have in your project and not in a empty new one, i think.

Gl hf with ur job, i hope u solve this.

Thanks!