how to

i am creating simple interior visualisation project for mobile. i started with default mobile project with starter content (see those yellow chairs and a table). it works fine but i need player to walk instead of flying. i dont need to put a rigged character into this. i just want your eyes to remain the same level above the floor without diving into floor or hitting the ceiling. is there a way to just constrain z coord? or some other way to have player Z constant? thank you in advance for any help.

Just change the player type in the game mode

I forgot to mention i am using UE4.21. It looks a bit different. not sure what to click?

or like here in project settings. why are options greyed out?

You only need it in the level, unless you want to override all levels.

Here’s a vid, it’s the same concept in 4 and 5

I guess what i should do is to create new gamemode blueprint, switch it on in settings and change default pawn (flying) to character (walking). When i did that my character would not move or rotate. Why?

1 Like

Hey there @hundredcaws! If you changed the gamemode you’ll also likely have to set your the default pawn to your character and make sure your PlayerController is chose as well. Without both of these your character may not spawn, or your player controller could be empty and wouldn’t retain inputs.

I’m just checking, you have the first person assets as part of this project, right?

Then you could just use the first person gamemode.

If you don’t have those assets, you can add them. In the content browser, right-click

image

and

I guess i got no first person assets in my project. But i found another solution. I built a blueprint to constrain z axis of my pawn. Get location vector, break vector, copy x y, set constant z, make vector, set location.