Download

How to walk "inside" a mesh?

Hi. There’s something that I still haven’t figured out about collisions. I have made a ruined stone house, and it seems it’s surrounded by some invisible wall. I can’t walk through the walls which is fine, but when I want to step inside the house some kid of invisible wall is blocking me the way. The same thing happens when I’m dropping the character inside a room, the character gets stuck as if the whole room area was solid.

1482008458-ruinedfort.jpg

How can I activate collisions for the walls only?

Your whole mesh is wrapped in a bounding volume for collision.
If you open the static mesh in the staticmesh editor, you can see it if you turn on collision.

What you can do:
Either change the collision to “Use complex for simple” in the static mesh details.
Or, reimport the various wall pieces as individual meshes. As they have thier own collision then, you can walk between them. Additionally they would have each their own lightmap.
Also the engine can cull them more effectively when partially out of sight, etc…

Just to add to that. You also need to check the box further down the details panel to use custom collision.

Unreal automatically attempts to create a collision mesh for the mesh on import (most of the time being inaccurate like what you are facing). KVogler has the right idea.

Thanks for the answers! I imported each wall pieces separately as Kvlogger suggested and it’s working great.

Edit: Use complex for simple also works great. Thanks for your great help and fast answer, awesome community. :cool: